16

There was a way to register URL protocol handlers with Gconf, which is now obsolete and there seems to be no way to do the same with DConf (or Gsettings, its recommended wrapper).

How do one properly register an URL protocol handlers since DConf?

Additionally, something looks strange to me (as I don't understand it), on my Ubuntu 12.04

The protocol apt:// should be handled by the apturl command. It is so with my Opera browser, but only because I added this specific association using the browser's configuration facility. Otherwise, in the rest of the environment:

  • Running xdg-open apt://foo.bar opens elinks (my www-browser alternative).
  • Running gnome-open apt://foo.bar opens the Software Center.
  • Opening gconf-editor, I see a key /desktop/gnome/url-handlers/apt whose value is apturl "%s" and it's enabled. This configuration seems to be ignored, which is reasonably expected, as GConf is considered obsolete.
  • Opening dconf-editor, I can't see anything related to URL handlers or protocols in /desktop/gnome

It looks a bit messy to my eyes (just teasing with this wording, nothing bad)

What's underneath?

Side note: I'm looking for something which preferably works even when the full desktop environment is not loaded, like when running an i3wm session with only gsettings-daemon (and other stuff unrelated to this case) loaded.

Update

Another way to “register” a protocol handler is with *.desktop files and their MIME-Type; e.g. MimeType=application/<the-protocol>;.

I found a /usr/share/applications/ubuntu-software-center.desktop with this content:

[Desktop Entry]
Name=Ubuntu Software Center
GenericName=Software Center
Comment=Lets you choose from thousands of applications available for Ubuntu
Exec=/usr/bin/software-center %u
Icon=softwarecenter
Terminal=false
Type=Application
Categories=PackageManager;GTK;System;Settings;
MimeType=application/x-deb;application/x-debian-package;x-scheme-handler/apt;
StartupNotify=true
X-Ubuntu-Gettext-Domain=software-center
Keywords=Sources;PPA;Install;Uninstall;Remove;Purchase;Catalogue;Store;

This one explains why gnome-open apt://foo.bar opens the Software Center instead of apturl.

So I installed this apturl.desktop in ~/.local/share/applications:

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Terminal=false
Exec=/usr/bin/apturl %u
Name=APT‑URL
Comment=APT‑URL handler
Icon=
Categories=Application;Network;
MimeType=x-scheme-handler/apt;

After update-desktop-database and even after rebooting, both xdg-open and gnome-open still do the same and ignore this user desktop file, which as usual with user desktop‑files, should override the one in /usr/share/applications/.

Maybe there is something special with desktop files specifying x-scheme-handler MIME type and they are not handled the usual way.

The desktop‑file way does not answer the question.

9

Open ~/.local/share/applications/mimeapps.list and add a line like:

x-scheme-handler/apt=apturl.desktop
  • Ya, I could figure it for HTTP, MAILTO and some others. – Hibou57 Feb 26 '16 at 20:29
  • There is no such folder. I did a search from root, and didn't find it. – Vlas Bashynskyi Aug 12 '16 at 13:58
  • @VlasBashynskyi, the location of mimeapps.list may vary. I would suggest to run a search for the file name. – Hibou57 Aug 16 '16 at 14:24
3

xdg-mime

Maybe more elegant (change "apt" for any new other scheme):

  1. Check registered mime-types in /usr/share/applications/defaults.list.
  2. Add the apt.desktop file to ~/.local/share/applications/ or /usr/share/applications/ (here examples).
  3. update-desktop-database - Build cache database of MIME types handled by desktop files
  4. Register a protocol with

    xdg-mime default apt.desktop x-scheme-handler/apt`
    

    This will append the new MIME Type for the scheme to ~/.local/share/applications/mimeapps.list. You can register the new mime-type for all users on the system sudo xdg-mime install --mode system <xml file>.

Test with xdg-open "apt://foo.bar"

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.