8

This just recently started happening, and I'm not sure why.
Doesn't bother me too much, as I usually apt-get update/upgrade when needed, but it is kind of annoying.

Just curious if anyone has seen this, and/or knows how to fix this.

blank updater

2
  • 2
    Possible duplicate of Invisible updates
    – karel
    Oct 9 '18 at 8:57
  • possibly, but you can tell from the screenshot that the entire window is blank, so it's not an issue with possible updates not showing. It was a bug in update-manager Nov 9 '18 at 3:22
2

I had been having the same problem for a couple of weeks. I had not interrupted any updates, the only unusual thing I'd done was un-selected a suggested update (I think it might have been an update to bsdutils, since there as something that looked dodgy about it - some missing information about the proposed update). After that, each time a software update window appeared, it would contain just the title bar and border. I could resize it, but it was blank.

I tried the above advice, but dpkg does not support those options. I suspect the advice was meant to say: 'sudo apt-get update' and 'sudo apt-get upgrade'.

I did that, and it downloaded and update a bunch of stuff. I also had a reboot pending, but I chose not to do that.

None of the above helped.

I couldn't find the update process easily using ps, but did track it down via the GUI "System Tools" -> "System Monitor" tool. From that I discovered the equivalent command line: /usr/bin/python3 /usr/bin/update-manager --no-update --no-focus-on-map If I ran that, it worked normally.

However, I noticed that regardless of whether update-manager was visibly running (either the small blank window the system would occasionally produce, or a normal one if I ran it from the command line), that there was always an "Update-manager" process running.

Thinking that maybe some part of update-manager had somehow gotten "wedged", I selected it and chose "End Process", ignoring the dire warnings. From that point on, the problem of the small blank Software Updater window vanished.

2

I had this very same issue and as user75601 pointed out it seems to be caused by an orphaned update-manager process. You can quickly check from terminal with:

pgrep -fl update-manager

and can kill all the update-manager processes with:

pkill -f update-manager

Start the update manager as usual from Dash or Launcher and all should be normal again.

0

I had this problem today, after I forgot update-manager was updating my system and I logged out, aborting the update-manager. Upon logging back in, update-manager could only show a zero-size window, only the window border was visible.

I did have other issues, which I had to clean up using dpkg (you should google for any specific dpkg-related problems you might have, and fix them).
In my case, I had to remove a lock on and then 'sudo dpkg update' and 'sudo dpkg upgrade'.

Then I rebooted, and my update-manager was back to normal.

So I suspect that my update-manager was confused due to the invalid state that I had after aborting my software installation. I had to use dpkg to clean up and finish the pending installations and reboot. The reboot was probably necessary due to a kernel update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.