1

This is the error. It comes up when I paste and enter the installation code (which I get from the Package Control website) and each time I open up Sublime Text.

Package Control

Your system's locale is set to a value that can not handle non-ASCII characters. Package Control can not properly work unless this is fixed.

On Linux, please reference your distribution's docs for information on properly setting the LANG environmental variable. As a temporary work-around, you can launch Sublime Text from the terminal with:

LANG=en_US.UTF-8 sublime_text

I had the same problem with Ubuntu 13.04 so it's probably not version-dependent.

  • So what have you found when searching the Ubuntu docs for setting the LANG variable? – MattDMo Aug 21 '14 at 19:30
  • echo $LANG gives en_US.UTF-8 so it looks like my LANG variable is already set to what Sublime Text requires. – user1837378 Aug 21 '14 at 20:49
0

I found some language settings were missing on my install of 14.04 that make this an easy fix:

  1. Install the language settings for system settings

    $ sudo apt-get install language-selector-gnome
    
  2. Go into Language settings (should be visisble from system settings now) and set your language to English (US) and apply system wide

  3. Restart

0

The environmental variables definied in .bashrc and/or .profile files are not seen by graphical applications like Sublime Text. To solve this problem, add a line in /etc/profile like this:

export LANG=en_US.UTF-8

If you prefer, you ca also use export LANG=it_IT.UTF-8 or any other language (ES, FR,...).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.