I'm having some problems with Google Chrome and my touchscreen in Ubuntu 14.04.

Basic touchscreen usage works fine, but if I double-tap on the touchscreen (the gesture for a right-click, as far as I can tell), then every time I touch the screen after that, it acts as if I've right-clicked.

This problem appears to be unique to Chrome; xterm, for example, acts normally.

Any suggestions?

Is there a way to get touchscreen events to act identically to mouse events? For example, I found where I can disable touch events (using chrome://flags/#touch-events), but that completely disables tap for left click.

Is anyone successfully using a touchscreen with Google Chrome in Ubuntu 14.04? (I'm working on this for a kiosk-style setup, so I'm using Ubuntu Server and nodm instead of Unity or another desktop shell, and my hardware's a little unusual also.)

  • 1
    I'm running full Ubuntu 14.04 with normal hardware, but having exactly the same problem. – Olli Feb 9 '15 at 15:35
  • Have you tried using xev to see what the actions end up as, don't know how it works for touch though. See www.x.org/archive/X11R7.7/doc/man/man1/xev.1.xhtml – DaveM Jun 18 '15 at 16:23
  • @DaveM - We tried xev and couldn't see anything that would indicate the problem. – Josh Kelley Jun 22 '15 at 14:03
  • @JoshKelley you likely need to run it before and after the problem arises, so as to get the base point and the fault. Otherwise I see you have a solution – DaveM Jun 23 '15 at 18:59

There are at least one possible solution that worked for me. :)

That problem could be solved for me with Chrome's --touch-devices command line parameter.

Determine X's input device id in a console by

xinput list

leading to

google-chrome --touch-devices=10

on my system.

To make Chrome always use this CLI flag, see:

How to set CLI flags for Google Chrome?

Chrome + Touchscreen + Unity (14.04)

  • We'd stumbled on --touch-devices while investigating another issue and didn't realize it could help here as well. I'm not in a position right now to test if this fixes the problems we were having, but it makes sense; thanks. – Josh Kelley Jun 22 '15 at 13:51

This issue is very elusive for me so I'm not sure if my current fix will actually stay fixed. But what I did was to comment out any occurrence of Option "SoftButtonAreas" in /usr/share/X11/xorg.conf.d/50-synaptics.conf. However, this is not the way to do it. Rather I should override this file in something like /etc/X11/xorg.conf.d/my-synaptics.conf. I'll reboot and see if that breaks it again...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.