I just got an invitation for Google+, the video conference feature "hangout" is the first feature I checked out, and unfortunately the webcam is not working, the mic and speakers work ok. When I started it, it recquired me to install a new version of Google Talk plugin

  • It seems that now the gmail chat and the chat within empathy( that used to work) does not work either.

  • in the settings of the webcam in google hangout window my only option, is gspca driver.

    • Notice that my cam had problems with skype, and I had to go around it by

      env LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype

How can I make it work?

  • Does it work within Gmail? Gmail had this feature ever since in-mail chatting was introduced.
    – Oxwivi
    Jul 1, 2011 at 11:54
  • it did work, with gmail and within empathy. but the last time i checked was long ago... i'll try to check it today
    – suli8
    Jul 1, 2011 at 12:11
  • no it is not working now! it must be the new plugin cause it used to work before... what to do?
    – suli8
    Jul 1, 2011 at 12:34
  • 1
    I'll be honest, I don't know. I'm just asking you for information that might help you get help. Add the new info to the question.
    – Oxwivi
    Jul 1, 2011 at 12:35

4 Answers 4


Well I managed to solve the problem. I will post it for future use. It turns out that it is similar to the Skype issue.

  1. Open the terminal and launch nautilus as root:

    sudo nautilus
  2. Rename /opt/google/talkplugin/GoogleTalkPlugin to /opt/google/talkplugin/GoogleTalkPlugin.real

  3. Create a new /opt/google/talkplugin/GoogleTalkPlugin

  4. Enter this text in the new file, and save it (make sure that the libv4l package is installed if not get it through synaptic):

    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /opt/google/talkplugin/GoogleTalkPlugin.real   
  5. Give the new file the permissions to run, by going to properties, permissions and allow to execute.

That's it. For me it worked. In case of a newer version of the plugin in the future you might need to do so, with the new one (renaming).

  • Instead of adding [solved] to the title, just mark your own answer as accepted.
    – Vitor Py
    Jul 2, 2011 at 1:53
  • i can't mark it till tomorrow so untill then i was thinking of adding the [solved] mark.
    – suli8
    Jul 2, 2011 at 2:47
  • 3
    Same approach worked for me on Arch Linux 64bit when I changed the preload path to /usr/lib32/libv4l/v4l1compat.so
    – Daenyth
    Jul 2, 2011 at 20:58
  • this fix works with cheese and empathy, but it does not work for the gtalk plugin for firefox. i'm on natty 64bit
    – Joris
    Jul 9, 2011 at 21:48
  • Clever! Works with Chrome on Natty with Unity Jul 13, 2011 at 0:24

I use Ubuntu too and at the first time I have had the same problems with google Hangout. But now I have the solution for you:

First you must install the voice and video- plugin from google.

Then you open this plugin with Ubuntu Softwarecenter. If you have done that, you have to go to Multimedia and there you must install the Google voice and videoplugin at the second time.

After all you can start the Hangout!


I have wrote this little script according the instructions suggested by @suli8.

If you save it to a file (lets call it apply-googletalk-v4l1-workaround.sh, but can be anything), then you could apply it by:

sudo bash apply-googletalk-v4l1-workaround.sh

This might help in avoiding small mistakes.



mv $plugin_location $plugin_location.real

cat > $plugin_location <<EOF
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so $plugin_location.real

chmod +x $plugin_location

killall GoogleTalkPlugin

I have seen in an above comment that the workaround made Google Talk stop working in Gmail. I guess it was because of some small error in executing the steps. Using this script might avoid that error.


I believe you can uninstall any package installed using the software centre. Try removing it and see what happens.

There shouldn't be any reason why it would break the compatibility with your webcam as I thought it was just a browser plugin set.

  • 2
    it requires the plugin, if i uninstall it, it won't work. as i said it's the google-talk plugin.
    – suli8
    Jul 1, 2011 at 23:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.