1

I am using Xubuntu 14.04 with Firefox 31 as my browser. I can not get pay-for-view movies from Google Play, YouTube or Acorn (tv) to work. Regular YouTube videos work fine for some reason--as do other video clips--it's only on the paid stuff that I can't get it to work. If I shut down and reboot into Windows 7 (also using Firefox 31), they stream just fine.

I assume this is something to do with flash since only the operating system changes. And since Adobe no longer upgrades flash for linux, my flash is probably hopelessly out of date. Is there an alternative or workaround (simple please--I am not a computer geek, just a user who hates Microsoft) that will allow me to watch movies/tv in Xubuntu? I want to reformat and completely get rid of Windows, but until I can figure out how to get these to stream in linux, I need it. I have tried Chromium and Opera on Xubuntu, but the problem persists.

The folks at Acorn tv recently switched servers to Brightcove, and the second they did that, all of the linux people suddenly couldn't watch their content any more. (It worked fine before the switch.) I contacted them (4 times!!!) and they assured me they were working on it, but as of yesterday, they suggested I unsubscribe and offered me money back because they said...

"I'm sorry but we are unable to offer guaranteed support on Linux. You should be able to watch DRM protected content if the browser you use supports Flash version 12.2 or higher. For more info, please see: http://helpx.adobe.com/flash-player/kb/protected-video-content-play.html."

But then they added...

"If you really love the content and you still wish to watch, you might try subscribing through the YouTube channel instead. All of the content is the same and YouTube is able to work on more platforms. The channel is at www.youtube.com/acorntv."

Problem is, when I pay to watch movies on YouTube, I can't. Why would this be different? Or is it? I am lost. Can someone please suggest something?

Thanks!

1

You might try using Google Chrome. Your movies might require (as you hinted to) an updated version of flash. Adobe stopped supporting Flash for Linux, so other browsers will either depend on workarounds are an outdated version of flash.

Google has a license with Adobe which they incorporate in their chrome browser. Google also has native support for Linux. So running Google Chrome for your flash support might be better resolution than rebooting into Windows. I run different browsers depending on particular instances for various site support. While my preference is Opera, I still retain Firefox and Google Chrome for sites that are more optimized for those browsers.

0

AHAH! Just when I had given up, I found a solution!!

When I tried to stream from Acorn TV I got the message "update to Flash 12" which can't be done directly. Google Chrome does NOT solve the problem. Apparently only Flash 12.2 and later versions will handle the DRM system used.

Pipelight is a special browser plug-in which allows the Windows plug-ins to work inside a Linux browser. Michael Muller and his team have made a brilliant job of this, and have made a great web site which explains everything at https://launchpad.net/pipelight

The installation is very clearly explained and only took 4 lines in the terminal. I am using Linux Mint, so followed the steps for Ubuntu, found here [http://pipelight.net/cms/install/installation-ubuntu.html]

Many thanks to the Pipelight Development Team!!!

protected by Community Feb 11 '15 at 19:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.