0

I have an Acer C720 converted over to Linux (Ubuntu 14.4). The WiFi used to work but it won't work at my current hotel. It says I'm connected though. Password is correct. It just says that every page I go to is unavailable. If I boot the machine as a Chromebook then I'm fine and can access all. Similarly if I use my nexus 7 then all's OK. How can I find out what's wrong? Mike

1
  • Please add the output of: ps -ef | grep dhclient to your question. Aug 20, 2014 at 15:16

1 Answer 1

1
  1. create a file:

    vi /etc/modprobe.d/ath9k.conf

  2. enter the following into that file:

    options ath9k nohwcrypt=1

  3. reboot

check this out

5
  • A little explanation: passing the nohwcrypt parameter to the ath9k kernel module will cause it to use the software layer for encryption tasks, instead of relying on hardware capabilities. This assumes that the OP's problem is related to wireless encryption (however, the Reddit link provided deals with a slightly different issue met when using both WiFi and Bluetooth). Aug 20, 2014 at 15:30
  • @msnfreaky This assumes his Acer uses an Atheros wireless card. Are you sure it does?
    – chili555
    Aug 20, 2014 at 16:02
  • The WiFi used to work under ubunto a day or two ago. It just won't work at my current hotel
    – user72727
    Aug 20, 2014 at 16:45
  • @chili555 The Acer C720 comes with a AR9462 WLAN+BT chip.
    – msnfreaky
    Aug 23, 2014 at 6:48
  • I was facing the same issue as the OP and this fix solved the problem for me. On an Acer C720 running elementaryOs Luna. Oct 2, 2014 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.