This question already has an answer here:

I have been getting update notifications for a few weeks now but whenever I attempt to install them I get this message;

The upgrade needs a total of 74.6 M free space on disk '/boot'. Please free at least an additional 29.8 M of disk space on '/boot'. Empty your trash and remove temporary packages of former installations using 'sudo apt-get clean'.

First of all I don't have permission to access /boot (don't know why as its a standalone machine and i'm the only user).

Secondly, I emptied the trash;

Thirdly, I launched Terminal and entered sudo apt-get clean I was a asked for a sudo password. I entered my system password. Re-entered sudo apt-get clean. The cursor stopped blinking - I assumed it was doing it's "thing".

I let it go for about 10 minutes then exited Terminal. Tried to install the updates but just got the same message.

Is there something i'm ignorant of?

This is the output I get from the command df -h and I have no idea what it all means! @Tim, What's bash and why am I denied access to fstab and /boot?

mike@mike-MS-7800:~$ /etc/fstab
bash: /etc/fstab: Permission denied
mike@mike-MS-7800:~$ df -h
Filesystem                   Size  Used Avail Use% Mounted on
/dev/mapper/ubuntu--vg-root  913G   11G  856G   2% /
none                         4.0K     0  4.0K   0% /sys/fs/cgroup
udev                         1.7G  4.0K  1.7G   1% /dev
tmpfs                        335M  1.6M  333M   1% /run
none                         5.0M  4.0K  5.0M   1% /run/lock
none                         1.7G   14M  1.7G   1% /run/shm
none                         100M   52K  100M   1% /run/user
/dev/sda2                    237M  182M   43M  81% /boot
/dev/sda1                    487M  3.4M  483M   1% /boot/efi
/dev/sr1                      31M   31M     0 100% /media/mike/Optus Mobile

I ran this from the terminal and all is now working.

dpkg -l 'linux-*' | sed '/^ii/!d;/'"$(uname -r | sed "s/\(.*\)-\([^0-9]\+\)/\1/")"'/d;s/^[^ ]* [^ ]* \([^ ]*\).*/\1/;/[0-9]/!d' | xargs sudo apt-get -y purge

marked as duplicate by Benoit, karel, Radu Rădeanu, Eliah Kagan, Warren Hill Aug 21 '14 at 6:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Your hard drive isn't big enough for these updates, you have run our of space. So you need to delete whatever you can (I suggest emptying the downloads folder - mine is ~ 40GB so yours could be quite big). – Tim Aug 20 '14 at 7:39
  • In Terminal try : 'sudo nautilus /boot' (without the quotes) to access /boot as superuser. – user218329 Aug 20 '14 at 7:43
  • Try with my answer here it's duplicate of this question – αғsнιη Aug 20 '14 at 7:45
  • To Tim, thanks for that but my hard-drive is 1TB and I haVE 923Gb free. – Mike Aug 20 '14 at 7:54
  • Right - it would have been sensible to tell us that, otherwise it looks like you have run out of space, like the message says. Are you sure your ubuntu partition uses all that space? – Tim Aug 20 '14 at 8:31

Browse other questions tagged or ask your own question.