6

Since i upgraded to kubuntu 14.04, my Eclipse crashes at different situations. Mostly i can "simulate" it when going to project properties and press ok. Then it always crashes.

My system:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.1 LTS"

My Java:

java version "1.8.0_05"
Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.5-b02, mixed mode)

My ADT Version:

Android Development Toolkit
Version: 23.0.0.1245622

I already tried to add this in adt-bundle-linux-x86_64/eclipse/configuration/configuration.ini

org.eclipse.swt.browser.DefaultType=mozilla
-Dorg.eclipse.swt.browser.DefaultType=mozilla

Error:

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fe049eb1718, pid=5964, tid=140601811232512
#
# JRE version: Java(TM) SE Runtime Environment (8.0_05-b13) (build 1.8.0_05-b13)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.5-b02 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libgobject-2.0.so.0+0x19718]  g_object_get_qdata+0x18
#
# Core dump written. Default location: /home/maddin/core or core.5964
#
# An error report file with more information is saved as:
# /home/maddin/hs_err_pid5964.log
Compiled method (nm)   28866 4166     n 0       org.eclipse.swt.internal.gtk.OS::_g_object_get_qdata (native)
 total in heap  [0x00007fe051da6790,0x00007fe051da6af0] = 864
 relocation     [0x00007fe051da68b0,0x00007fe051da68f8] = 72
 main code      [0x00007fe051da6900,0x00007fe051da6ae8] = 488
 oops           [0x00007fe051da6ae8,0x00007fe051da6af0] = 8
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

Now, as soon as i change SystemSettings -> Application Apperance -> GTK -> GTKn-Design to something else but "oxygen-gtk" this crash doesn't happen anymore.

But the application appearance also is ugly. Beside that i get a lot of errors/warnings like that:

(SWT:6148): GLib-GObject-CRITICAL **: g_closure_add_invalidate_notifier: assertion 'closure->n_inotifiers < CLOSURE_MAX_N_INOTIFIERS' failed 

or other GTK warnings from the particular design, not having theme-engine.

Which actually doesn't cause any crahs it seems so far.


So i have 3 options:

  • accept crashes
  • accept warnings (maybe the best choice)
  • accept ugly design

What can i do to solve this issue without changing the design settings?

  • Sad, nobody even answers. Cant believe i am the only one having this issue. – nouseforname Aug 31 '14 at 19:41
  • You are in no way the only one. You just saved me lots of nerves as no other tip helped. But now I am stuck with the ugly UI as you are... – zmilojko Sep 12 '14 at 15:02
  • One tip: you can decrease the font. Makes it a bit less ugly. – zmilojko Sep 12 '14 at 15:11
  • @zm did it already ;) – nouseforname Sep 12 '14 at 15:13
8

You've hit the following bug that is not fixed yet: https://bugzilla.gnome.org/show_bug.cgi?id=736323 .

Workaround:

  1. Find your GTK2 theme config file. For Oxygen it is /usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc.
  2. Edit the theme config file (as root): change GtkComboBox::appears-as-list from 1 to 0.
  • This made Comsol Multiphysics stop crashing on Kubuntu 14.04. – foobarbecue Mar 18 '15 at 11:25
  • This is still an issue with 14.04... even in 2016. Thanks for the quick-fix. – david1024 Jun 8 '16 at 18:01
  • Nice, this this a general fix for numerous Java GTK2 programs; in my case the Android SDK and AVD Managers were constantly crashing – Ralph Versteegen Sep 28 '18 at 14:22
1

Had the issue with Tizen SDK (java) and it worked after I changed default GtK+ themekde-gtk-theme

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.