This question already has an answer here:

I'd like to activate ctrl+alt+backspace on multiple pcs (Ubuntu 14.04) using

dpkg-reconfigure keyboard-configuration

I don't want to do the dialog every time so i tried:

debconf-get-selections | grep "^keyboard-configuration" > config.dat

on a host where i answered the dialog with the desired answers

On the host where i want to do it non interactively i tried:

debconf-set-selections config.dat

dpkg-reconfigure -f noninteractive keyboard-configuration

it ran without asking, but afterwards the selections where reset to the default values

How can i get dpkg to use my predefined values? Or is there another possibility to enable the ctrl+alt+backspace for all users without going through dialogs?


to summarize: my problem is that

dpkg-reconfigure -f noninteractive keyboard-configuration

doesn't seem to respect my preseeded selections. Can anyone find something wrong in the procedure how i try to do it or could this be a bug?

marked as duplicate by muru, Richard, Tim, Eliah Kagan, Eric Carvalho Aug 20 '14 at 12:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Use the gsettings command in this answer: askubuntu.com/a/367995/158442 – muru Aug 19 '14 at 15:50
  • With gsettings i managed to activate it only for gnome. I want it to work everywhere. – Nikolai Aug 19 '14 at 16:05

Browse other questions tagged or ask your own question.