1

As the title states...it just stopped unpacking/installing.

"Preparing to unpack .../lirc_0.9.0-0ubuntu5_amd64.deb ..."

then stopped in its tracks. Everything else is still running.

The update manager process is still alive; if I hit ctrl-c, it gives me the warning message about leaving the system in a broken state. Also, if I run top, there is a process called "trusty" which is still running. I have NOT killed either process.

lsb_release -a gives:

LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch Distributor ID: Ubuntu Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty

I assume that if I try to restart update-manager, I won't be offered the option to upgrade again.

Anyone have a way I can get the update-manager/dist-upgrade process to simply finish the upgrade?

Thanks!

1

I have had the update manager fail on me on a few occasions as well (e.g. when running out of free disk space). In most (if not all) cases I was able to restart it and finish the upgrade without any problems. Note that I didn't reboot the machine in this half-upgraded state. I can imagine that that would break it. So, no guarantees, but simply exiting the update-manager and restarting it may just work.

  • Tried that. It still hangs up while trying to unpack the same package as in my initial question. I tried removing it, but it won't do that (wanted me to run dpkg --configure -a, which I tried doing, no joy; trying to re-install it caused the same hangup; deleted the package from /var/cache/apt/archives (bad download?)- but still didn't work). So...I can't remove it, I can't reinstall it, and trying to do anything else causes it to continue to hang up when attempting to unpack it (even though it's no longer in the download directory). The upgrade should finish if I can get around this. Thx! – Bob Sully Aug 20 '14 at 2:40
  • Tried this also: dpkg --remove --force-remove-reinstreq lirc and it hangs up while trying to remove the package. root@vader:~# dpkg --remove --force-remove-reinstreq lirc dpkg: warning: overriding problem because --force enabled: dpkg: warning: package is in a very bad inconsistent state; you should reinstall it before attempting a removal (Reading database ... 273334 files and directories currently installed.) Removing lirc (0.9.0-0ubuntu1) ... (hang) – Bob Sully Aug 20 '14 at 2:50
  • There is plenty of free disk space, btw. Thanks. – Bob Sully Aug 20 '14 at 3:13
  • OK...I was able to get rid of that package by editing /var/lib/dpkg/info/lirc.postrm (added "exit 0" at the beginning of the file). After removing it I was able to finish the upgrade. Rebooting now. Fingers crossed. – Bob Sully Aug 20 '14 at 3:35
0

This is a pretty old question, but I recently ran into the same exact problem.

Looking through the running processes I noticed /bin/sh /etc/init.d/lirc stop in the list.

I killed that process (sudo kill <pid>) and the upgrade picked right back up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.