0

I purchased a Toshiba C-50-B-P-0010 about a week back, it did not come pre-installed with any OS. I have installed Ubuntu 14.04. The function keys are not responding properly. If i press F3 which is for brightness, it put the laptop to sleep! I have tried all the solutions suggested in the following link. One difference i observed after following all the suggestions is that i can change my brightness through my system settings. But the function keys are still not working as they should be. Touch pad on/off is also not responding.

Brightness control doesn't seem to work on a Toshiba Satellite M115 laptop

I'm not very good at using the terminal, so please give detailed suggestions. One of the suggestions is to update my BIOS, but the Toshiba India website drivers page doesn't have any BIOS for this model.

0

I've just got a Toshiba C50-B-14D model. I was able to make most of the function keys working with the following procedure:

  1. Make the /etc/udev/hwdb.d/70-keyboard.hwdb file with the following content (you will need root privileges to make the file):

    #Satellite C50-B
    keyboard:name:Toshiba input device:dmi:bvn*:bvr*:bd*:svnTOSHIBA*:pnSATELLITE*C50-B:pvr*
     KEYBOARD_KEY_13c=brightnessdown
     KEYBOARD_KEY_13d=brightnessup
     KEYBOARD_KEY_13e=switchvideomode
     KEYBOARD_KEY_13f=f21                                   # Touchpad toggle
     KEYBOARD_KEY_158=wlan
    

    Note that it is important to have exactly one whitespace before the lines starting with KEYBOARD.

  2. Run sudo udevadm hwdb --update
  3. Run sudo udevadm trigger (This command would save you from restarting the machine, but if it doesn't work, try restarting the machine.)

After this the only key which do not work for me is the Wifi On/Off key.

To find more information on this process you can look e.g. here or here.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.