Earlier today my Unity desktop disappeared: I got a black screen with white text, but it disappeared too quickly for me to read. When the desktop reappeared, it was the Ubuntu Classic desktop. I used $ unity --reset but that did not do anything. I tried rebooting so I could choose unity from the list when I logged in, but although there was Ubuntu choice, there was no unity listed (but classic was listed). I was able to install Unity 2D and am using that, but really want to get 3D back.

I had been using Ubuntu without problems for several weeks when this happened. My graphics card is onboard a Dell Latitude desktop - a couple years old - and is reported as an Intel G33/G31.

I've looked at other requests for help here, and tried suggestions when they seemed to relate to similar problems, but nothing seems to work so far.

Any ideas? Thanks!

This is part of the output of my latest attempt to run unity --reset

Window manager warning: 0x3e01c35 () appears to be one of the offending windows with a timestamp of 1309472834.  Working around...
Window manager warning: last_user_time (1309473695) is greater than comparison timestamp (1126160).  This most likely represents a buggy client sending inaccurate timestamps in messages such as _NET_ACTIVE_WINDOW.  Trying to work around...
Window manager warning: 0x4c0046c (mdk@Habane) appears to be one of the offending windows with a timestamp of 1309473695.  Working around...
Window manager warning: Received a NET_CURRENT_DESKTOP message from a broken (outdated) client who sent a 0 timestamp
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x4c0046c (mdk@Habane)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
  • try to reinstall unity – shantanu Jun 30 '11 at 22:54
  • It sounds like compositing turned off. What happens if you try compiz --replace ? – Michael Martin-Smucker Jun 30 '11 at 22:55
  • 1
    I've tried to reinstall Unity, but it hasn't worked. In fact, things seem to be getting worse in lots of ways: I can no longer open Synaptic or the Software Center. – Kelley Jun 30 '11 at 23:17
  • And when I tried compiz --replace, it got a lengthy series of errors, some of them the same as I posted above. I'd guess that my hardware is failing, except that I can boot into Windows with no problems. – Kelley Jun 30 '11 at 23:18

I think you can bring up a terminal w/ CTRL+ALT+'T', then use apt-get to install unity,

"sudo apt-get install unity"

if you haven't tried that already...

  • Something very bad happened. Unity was only the first thing to go, and one by one other things began to fail. It seemed as though I had a virus, although I do really doubt that, but in the end it seemed best not to fight it. Fortunately I had backed up, so I went ahead and wiped the drive and reinstalled Ubuntu, and now everything seems good again (although it's been a long night). – Kelley Jul 1 '11 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.