7

I'd like to blacklist a couple of modules, namely drm, drm_kms_helper, i2c_algo_bit and i915 to forbid my integrated Intel GPU to be used, but to use my Nvidia MXM card instead.

I inserted the following lines into /etc/modprobe.d/blacklist.conf:

blacklist i915
blacklist drm
blacklist drm_kms_helper
blacklist i2c_algo_bit

Despite the above right after rebooting my laptop and typing lsmod I can see these modules loaded.

Why does my blacklist get utterly disrespected and what can I do about it?

1
11

After modifications in /etc/modprobe, you need to run:

sudo update-initramfs -u

I would be careful with disabling drm etc. I wouldn't be surprised if the nvidia driver depends on it (check with modinfo nvidia). Also, should you have any problems with your nvidia driver, then you will have a low resolution screen which might not support the GUI login at all.

Why would you disable the iGPU? The processor is already in use so I doubt if it saves any power or resources.

6
  • I wanted to deactivate the iGPU because I use the eGPU all the time and resume from suspend doesn't work. I thought that if I can remove these modules then the iGPU won't activate upon resume and I'll be able to successfully resume my laptop. Unfortunately, even though I can successfully blacklist the modules of the iGPU I cannot make resume work. – László Monda Jul 1 '11 at 13:26
  • You should create a new question for that, please include your hardware with the exact model type if possible. – Lekensteyn Jul 1 '11 at 20:41
  • There's at least 5 blacklisting questions on here that could be answered by this. – austinmarton Jun 23 '15 at 2:14
  • @austinmarton Which one exactly? You can also flag a post for moderator attention if you feel that it is a duplicat.e – Lekensteyn Jun 23 '15 at 6:15
  • @Lekensteyn sorry I meant the other way round! Your answer above could SOLVE a number of unanswered questions about why blacklisting isn't working (that I stumbled across myself) – austinmarton Jun 24 '15 at 2:44
1

In a similar situation to the OP, and heeding all of @Lekensteyn's good advice, blacklist i915 silently appeared to do nothing for me, even though lsmod said nothing was using i915, but install i915 /bin/false did the trick, causing Gnome 3 to automatically fall back to using llvmpipe.

0

None of these solutions worked on 16.04 LTS for i915.ko.

Even using module_to_blacklist.blacklist=yes or modprobe.blacklist=module_to_blacklist on the kernel commandline of grub did not work.

The (dirty) solution I found was to rename /lib/modules/4.4.0-22-generic/kernel/drivers/gpu/drm/i915/i915.ko and /usr/lib/xorg/modules/drivers/modesetting_drv.so and /usr/lib/xorg/modules/drivers/intel_drv.so

Unfortunately, external VGA screen is not recognized anymore :{

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.