I'm using the Desktop version of Ubuntu.

As soon as the installer starts, I type the Escape key which reveals the F1-F6 options. Tying Escape again gives this dialog:

**"You are leaving the graphical boot menu and starting the text mode interface."**

I select "OK", but the installer reboots... back into the graphical interface :(

How do I start the text mode installer interface?

2 Answers 2


Ubuntu eliminated its text-based installer some years ago for its desktop versions. The graphical installer is designed to be run from a full (live) Ubuntu desktop, and there was not enough demand for the text-based installer (for the desktop version, anyway) to justify the effort and complexity required to maintain two separate versions, each with its own code and quirks and bugs and updates. The two installers used different methods to install Ubuntu, so the developers were also afraid it would result in a variety of "standard installations", which could confuse users and complicate technical support, troubleshooting, and software updates.

My guess is the message you are seeing is a vestige of the time when the text installer was still a part of the normal desktop ISO; you could report that message as a bug, if you'd like.

There is still a text-based installer for Ubuntu Server, the Lubuntu "Alternate ISO", and for the Network Installer (a very small ISO that fetches the majority of packages from online mirrors at time of installation, as opposed to fetching them from the DVD or USB stick). Of these, I would recommend the Network installer, as it is a relatively small download and will allow you to install a full GNOME/KDE/MATE/XFCE/LXDE/Unity desktop from the text interface.

I'm sorry to be the bearer of bad news... Please let me know if this answer was helpful, or if you have any further questions.

  • Try this: Download Ubuntu...iso. Launch VirtualBox and create a new Ubuntu guest. Mount the ISO as a CD and run the installer the window is too small so I can't get to the Next button in the lower right Sometimes blind Tab gets to it. El Goog doesn't talk about the installer
    – Phlip
    Apr 28, 2020 at 21:31

You can add the following option to the boot command:


In order to do so, hit F6, then Escape, then add this after the dashes

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .