1

I want to install Firefox Aurora in Ubuntu 14.04 from the terminal (I know there are other ways) but I can't.

I've downloaded firefox-33.0a2.ca.linux-i686.tar.bz2 (linked from the download page) and extracted it. But I don't know how to install it from the terminal. There is no README file.

I've read that I should use the following commands:

./configure
make
make install

It doesn't work, it throws me:

bash: ./configure: No such file or directory

Also tried chmod a+x configure neither worked, it throws:

chmod: cannot access ‘configure’: No such file or directory

I can't find anything else about on the net. Running ./firefox, as muru suggested, throws:

./firefox: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

And that error is shown for sudo ./firefox as well.

This is a 64-bit Ubuntu system, and libstdc++6 package is installed at version 4.8.2-19ubuntu1. Purging and reinstalling the package doesn't make any difference to the problem.

Is there something that I'm missing? By the way, what about uninstalling it?

  • Welcome to AskUbuntu! The package doesn't need to be decompiled. You can just extract/open the tarball and doubleclick on 'firefox'. (This is a graphical based program). – No Time Aug 19 '14 at 4:50
2

As muru says, since you've downloaded a binary build of Firefox and not source code, running ./configure and make commands does not apply to your situation. Instead, you run it with ./firefox from the folder you unpacked.

This does not work now, but it should work nce you have the necessary libraries that Firefox. The problem is that you have a 64-bit Ubuntu system (amd64), but you're attempting to run the 32-bit version of Firefox Aurora (i386).

If you really want to run 32-bit Aurora on 64-bit Ubuntu, you can:

Your 64-bit Ubuntu system is capable of running 32-bit executables, but most of them, including this one, require the 32-bit versions of some system libraries. Those versions are available for your 64-bit system, but they are not installed by default.

So, if you really want to test the 32-bit version of Aurora on your 64-bit system, you can install libstdc++6 for the i386 architecture, by running these commands:

sudo apt-get update
sudo apt-get install libstdc++:i386

That should fix the error you're currently having, though you might instead get a similar error about another missing library. You could then fix that the same way, and eventually you'll have all the needed libraries installed.

To find out what package to install to get a particular file (in that case, it was libstdc++.so.6), you can use the Ubuntu package database. In the textbox under "Search the contents of packages," put in the filename and click Search.

The search results may look complicated at first, but it's usually navigable if you keep in mind that 32-bit library .so files on a 64-bit Ubuntu system are usually stored in the /usr/lib32 directory. In any case, feel free to expand your question if you have further difficulties.

But I'd suggest you test 64-bit Aurora instead:

To get the 64-bit version of Firefox Aurora, download a snapshot archive with x86_64 instead of i386 in its name. In this case, you should use firefox-33.0a2.ca.linux-x86_64.tar.bz2 instead of firefox-33.0a2.ca.linux-i686.tar.bz2.

You can get the 64-bit version by using a download link in the "Linux 64-bit" column of the Aurora download page, instead of the "Linux" column which lists downloads for the 32-bit versions.

In this case, the file you probably want is:

That's the current latest Aurora build for 64-bit Linux in the Catalan language. But note that in the future, there will be a later version (so in the future, that link should serve only as an example of what the URL looks like, rather than being the best download).

  • Amazing! I'll try this asap and report the result. I hope this will work. Thanks for your time and patience helping me! – Psyakz Aug 18 '14 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.