Recently I have been having problems with power consumption in Ubuntu, I am not exactly sure when this started but roughly about two weeks ago. Idle my laptop used about 9-10W of power, or at least it has done for the past two years. Recently it uses 16-18W and I have been trying to find out why. Using powertop it seems that my Network Interface is using 10W+ constantly even when not in use i.e. cable disconnected.

PowerTop showing power usage on my laptop

I have even seen it go as high as 30W for Network Interface: eth0 (r8169). Which seems like maybe a fault with PowerTop but my power usage reported elsewhere rises by the same amount.

I am not an expert but this seems queer. Is this normal and just something that I haven't noticed before?

It seems odd that Wifi uses barely any power but Ethernet uses a staggering amount, typically about 9-10W making my power usage roughly double what it was.

Things I have tried:

  • Using another driver for my network card - this seemed to drop power to around 5-7W mainly on the upper end of that but I didn't really use it long enough to test properly
  • Used an older kernel - no effect whatsoever.

Is there a way to correct this behaviour if it isn't normal?

I have added the services that were discovered by Zenmap:

Services and Ports running

I have an Apache server running and also have a local Windows network, unfortunately I don't see anything untoward.


I have just disabled networking via Network Manager and in PowerTop the Network Interface eth0 disappeared from the list, however the discharge rate did not go down by the same amount that eth0 was taking up (about 9W when networking was disabled) so it does seem that PowerTop is misreporting eth0's power usage. I've added a screenshot below.

Image showing powertop with networking disabled

Even so something is using more power and not appearing in PowerTop.

  • 1
    I also noticed a really high consumption for the Ethernet while nothing was plugged in. Simply running ifconfig eth0 down solved the issue. Battery life just tripled... Don't know what can be the cause of that high consumption... Just note that you need to replace eth0 by the name of your ethernet card (obtained from ifconfig) Nov 17, 2016 at 22:44
  • May I ask the name of the terminal font in the screenshot?
    – Anwar
    Nov 26, 2016 at 18:26
  • Sorry, took me ages to find this font as I had completely forgotten all about it, or what it was. It is called Hermit and is free. You can download it from the creators website - pcaro.es/p/hermit
    – user99306
    Dec 1, 2016 at 17:29

2 Answers 2


Well I have discovered what was causing my problems. Firstly it seems that PowerTop is misreporting power usage, the numbers never seem to add up, even after resolving this issue they still don’t.

It turns out that this issue was due to the recent update of the Intel drivers via the Intel Graphics installer. I also had Nvidia drivers and Nvidia Primus for my Nvidia card and it seems somewhere along the way they were either conflicting or had messed each other up.

Firstly I removed the Intel Drivers following the instructions in this Ask Ubuntu answer

This downgraded my drivers but didn’t completely resolve the issue. It seemed that my Nvidia card wasn’t completed being turned off, so I removed all the Nvidia drivers using:

sudo apt-get purge nvidia*

Then I installed bumblebee instead following the instructions in this Ask Ubuntu answer

Once that was done I rebooted and my Nvidia card was definitely off and my power usage was back to normal.

Power Usage back to normal

Ethernet power usage still seems high even at 3W, especially as I was using wifi at the time, but I think that PowerTop is just reporting it wrong. Apologies to anyone who spent time on this, I should have realised it was the graphics drivers but PowerTop threw me.


Install either zenmap (GUI) or netmap (CLI). Both of these tools will scan for running services, open ports etc. This will help you target the source of the activity. And if you ever feel like checking out what's going on in realtime etherape is a really good tool that shows all network-connections IPs and protocols.

  • If you don't have a printer you might want to disable cups and cups-browsed. I've noticed that sometimes cups will get stuck in a loop trying to find a printer when there is no device to connect to.
  • If you're not using pnp or any multicast you may want to disable avahi-daemon.
  • If you set up a static configuration instead of using DHCP you will no longer need to use dhclient.
  • Check to see if you are running some kind of a server. VLC is just one of many mediaplayers that can be set up for streaming of media throughout the local network.

  • If there are any Windows computers on your network, there is a security flaw in Windows that causes those computers to incessantly announce themselves to other computers on the network (I guess it's like router advertisements) although, it seems that would be less likely to cause your power consumption to be so high but could be one of many smaller contributing factors.

  • Thanks, I installed Zenmap and Etherape and I have added a picture of the running services that Zenmap found. I do use a printer and Windows network, I couldn't really see anything else there. I also ran Etherape for a while, but again saw nothing odd (that I could tell).
    – user99306
    Aug 19, 2014 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.