5

I installed the project NEON ppa in Ubuntu 14.04 to check out the new KDE in a VM. I can't seem to figure out how to change the display resolution. Its stuck at 800x600.

Edit: I'm using vmware player 6.0.3 with vmware tools installed. The unity desktop session runs at 1440x900. If I log out and switch to plasma5 session, its stuck at 800x600.

  • Same issue I am having with my Virtualbox guest. Ubuntu 14.04 with Plasma 5 packages installed. Both Unity and Plasma 5 have the same issue for me. I have tried downloading guest additions in virtualbox and devoting more resources to the VM. No luck – Callen L Aug 18 '14 at 20:09
  • possible duplicate of Higher screen resolution in VirtualBox? – Tim Aug 18 '14 at 21:45
  • 1
    im using vmware player. vmware-tools installed – koogee Aug 18 '14 at 21:48
  • 1
    It also happens to me. I have upgraded VMware Player to 6.0.4 build-2249910, and have tried open-vm-tools, but I get this bug: bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1362631 Have you reported your bug to: - VMware? I suspect they support Ubuntu and not Kubuntu - Ubuntu (via Launchpad) - KDE (bugs.kde.org) I wonder if it is related to bugs.kde.org/show_bug.cgi?id=337560 and Kubuntu does not have the fix yet. – Marco Parillo Nov 1 '14 at 20:31
6

I have the same issue and have the following workaround:

It is possible to set the resolution from a command line using 'xrandr'. Running just xrandr allows you to see the current resolution and the other valid resolutions.

From a command line you can run 'xrandr -s 1024x768' and the screen in VMware will reset to that size!

You can even set this at KDE startup by doing the following:

  • click KDE start icon
  • select System Settings
  • select Startup and Shutdown
  • click Add Program...
  • enter 'xrandr -s 1024x768' in the text box
  • be sure the "run in Terminal" checkbox is checked
  • follow the rest of the prompts to set it as a startup command.

The next time you log in, it will start at 800x600 but at the end of the login you will see the screen resize!

| improve this answer | |
  • Almost worked, but it reverts back to 800x600 right away still :( – jocull May 10 '19 at 15:56
  • @jocull, you probably did this, but... When you ran xrandr without operands, did you get a list of valid resolutions, and did you pick one of those? – cniggeler May 13 '19 at 16:10
  • I went back and tried this again just to be sure, but yes - I got a long list of valid resolutions and tried several, but they are reverted within a couple seconds at most. – jocull May 13 '19 at 17:24
  • Sorry, I don't have much else to offer. I remember that one needed a later version of VMware to allow it to automatically resize, but this is 3 years back now and I don't recall... Good luck, and post if you find a solution! – cniggeler May 15 '19 at 15:43
  • It might just be a quirk of virtualbox :) – jocull May 15 '19 at 18:01
2

If you try the xrandr command and it doesn't work:

  • Power off the VM
  • Go to display setting in Oracle VirtualBox and
  • Change the graphics controller

It may take a couple of tries to find one that works.

| improve this answer | |
0

Go to view → autosize → autofitguest in VMware vm window. Now stretch the vm VMware window and it will autosize for you

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.