2

I was curious. Someone said Kubuntu is awesome. So I installed it (sudo apt-get install kubuntu-desktop).

I didn't like it. Keyboard shortcuts that I became familiar with in Unity weren't working. It just felt too "Kids R Us" for me, like a toy OS, so I logged back into Unity and noticed some oddities. All my menus were jacked. The background of menus are now black and the text IN the menu is a dark grey so I can barely read my menus. A new square icon has appeared in the top panel with a DO-NOT-ENTER icon on it. Upon clicking it gives me ENGLISH, CHARACTER MAP, KEYBOARD LAYOUT, AND TEXT ENTRY SETTINGS.

Google chrome's tabs are now a weird white/grey gradient and my navigation buttons (back, forward, refresh) are a bubbly cartoon-ish blue and green.

So, I ran sudo apt-get purge kubuntu-desktop && sudo apt-get autoremove and rebooted. I still have 3 extra "skin(?)/distros(?)" available to me at the login screen when I click the Ubuntu icon. So looks like not everything got removed.

Any ideas? I really hope I don't have to re-install everything, again. And I learned "unity --reset" has been deprecated :(

1

I've experienced almost the exact same scenario (the main difference being me not using Chrome but Firefox, where I've experienced similar phenomena). What solved the issue for me was to remove ~/.config/gtk-3.0. (To make a backup and remove it run mv ~/.config/gtk-3.0{,.bak}.)

By the way, the indicator with the do-not-enter icon is the input source selector. After solving the issue it should show "En" rather than the do-not-enter icon. In any case it seems you don't need it (as you haven't got other options than English to select from), so you can just remove it from the text entry settings (disable "Show current input source in the menu bar").

As for the extraneous "skins" at login, they are defined in /usr/share/xsessions - you can remove the files corresponding to those options you no longer want from this directory.

0

rm -rf ~/.local/ ~/.cache/ ~/.config/ ~/.kde/ will reset most everything as far as your account goes. You could get more fine-grained than that if you looked in all of the "dot" directories for anything KDE related. You can also run dpkg-reconfigure lightdm to try to fix the login screen issues.

3
  • Thanks Zachary. Finally got around to doing this. It fixed my dark-on-dark menus but the goofey icons are still in Chrome. Also, I still have multiple options for different... skins(?), like: GNOME Flashback (compiz) GNOME Flashback (metacity) KDE Plasma Workspace Ubuntu (default) ...and I learned I cannot log back in as any of them because the weird menus come back. No biggie, I want to blow them all away anyway. Lastly, the boot up screen still says KUBUNTU :\ – 00fruX Aug 19 '14 at 23:38
  • sorry about the lame formatting on my comment, can't figure out how to do a simple line break! -- SHIFT + ENTER doesn't seem to work in comments – 00fruX Aug 19 '14 at 23:43
  • @Zachary, removing ~./local, ~/.cache, ~/.config and ~/.kde entirely is an overkill, and may cause the user to lose a lot of important information (hours worth of configuration). – Tom Mar 27 '15 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.