2

So, I'm not necessary new to Linux, I just never took the time to learn it, so please, bare with me.

I just swapped out one of my wireless cards from one computer to another. This wireless card in question would be a "Broadcom BCM4321 (14e4:4329)" or actually a "Netgear WN311B Rangemax Next 270 Mbps Wireless PCI Adapter", but that's not important. I've tried (but probably screwed up in the process) installing the "wl" , "b43" and "brcmsmac" drivers, or at least I think I did. Currently I have only the following drivers loaded:

eugene@EugeneS-PCu:~$ lsmod | grep "brcmsmac\|b43\|ssb\|bcma\|wl"
b43                   387371  0 
bcma                   52096  1 b43
mac80211              630653  1 b43
cfg80211              484040  2 b43,mac80211
ssb_hcd                12869  0 
ssb                    62379  2 b43,ssb_hcd

The main issue is that with most of the drivers available that I've installed, they will find my wireless network but, they will only stay connected for about a minute with abnormally slow speed and then all of a sudden disconnect. Currently, the computer is hooked into another to share it's connect so that I can install drivers from the internet instead of loading them on to a flash drive and doing it offline.

If anyone has any insight to the problem, that would be awesome. If not, I'll probably just look up how to install the Windows closed source driver.

Edit 1: Even when I try the method here, as suggested when this was marked as a duplicate, I still can't stay connected to a wireless network.

Edit 2: After discussing my issue with @Luis, he opened my question back up and told me to include the tests/procedures in the comments. Basically I did this:

  • Read the first answer of the link above when this question was marked as duplicate which involved installing removing bcmwl-kernel-source and instead install firmware-b43-installer and b43-fwcutter.
  • No change of result and contacted Luis in the comments, who then told me to try the second answer which involved removing my previous mistake and installing bcmwl-kernel-source
  • Now the Network Manger (this has happend before, but usally I fixed it by using a different driver) even recognizes WiFi exist (both non-literal and literal). Luis who then suggested sudo rfkill unblock all
  • rfkill unblock all didn't return anything, so I decide to try sudo rfkill list all. Returns nothing (no wonder rfkill unblock all did nothing).
  • I enter lsmod | grep "brcmsmac\|b43\|ssb\|bcma\|wl" and that returns nothing.
  • Try loading the driver by entering sudo modprobe b43 and try lsmod | grep "brcmsmac\|b43\|ssb\|bcma\|wl" again. Returns this:

    eugene@Eugenes-uPC:~$ sudo modprobe b43 eugene@Eugenes-uPC:~$ lsmod | grep "brcmsmac\|b43\|ssb\|bcma\|wl" b43 387371 0 bcma 52096 1 b43 mac80211 630653 1 b43 cfg80211 484040 2 b43,mac80211 ssb_hcd 12869 0 ssb 62379 2 b43,ssb_hcd

So to recap: Currently Network Manager doesn't recognize Wireless exists, b43 drivers are loaded and I've currently hardwired a connect from my laptop to the computer that's causing this.

Edit 3: So I just decided to try again to install bcmwl-kernel-source. It was able to find my network and it tried to connect. However, in never really succeeded and kept asking me for the network pass phrase. I give it the correct one every time but it keeps asking about three times and then stops trying. At this point I'm starting to research how to use ndiswrapper but haven't had any luck with that either.

Edit 4: After crying in a corner for about a month, I've decided to do a fresh install of Ubuntu and install the Broadcom STA drivers (wl.ko) right off their website. It does indeed find networks and seems to know how to connect to them, however, It will connect to them for a few minutes with very slow connection speed and then just drop. That was with the Wicd Network Manager too, with just plain old network-manager, it will keep asking for my password to connect to the network never actually connecting to the network.

0

I also have a Broadcom BCM4321 wireless card but

sudo apt-get install bcmwl-kernel-source

works perfectly for me on ubuntu 14.04.1

  • But is you PCI ID the same as mine (4329)? It could make all the difference from what I've researched. – Eugene Aug 21 '14 at 5:11
  • try the driver from here [link]broadcom.com/support/802.11/linux_sta.php -- see if it works – neo321 Aug 21 '14 at 14:53
  • I already have. – Eugene Aug 21 '14 at 16:21
  • Well then, i guess you can just switch back to windows then :) – neo321 Aug 21 '14 at 19:35
  • @Eugene is right. The PCI ID is what matters. brcmsmac works best for me. Besides, if Eugene needs to, he can use ndiswrapper and run the Windows driver with Wine. If the Windows driver seems to work so well, it should run just fine under Wine. – John Scott Oct 15 '14 at 13:10
0

I also have this exact card, and have also recently switched to Linux. I also did extensive testing, and ended up just buying a cheap Linksys AE2500, which works fine for me through ndiswrapper. The reason is simple: The Netgear card works in the 32-bit version of Ubuntu, but not in the 64-bit version, and I have 8GB of RAM in my system.

Honestly, I can't remember if it's the b43 drivers or the wl ones, but it's not really that hard to switch them out thanks to the Software & Updates GUI. Besides, if I remember right, whichever ones were loaded by default were the ones that worked.

tl;dr version: Try the 32-bit version of Ubuntu. Strange as it may be, it worked for me, though you'd be sacrificing certain abilities, especially if you have more than 4GB of RAM.

  • Ew. Thanks, but do you know if there's a way to "emulate" a 32 bit version of ubuntu for the network drivers? – Eugene Nov 12 '14 at 23:00
0

I have the same card BCM4321 (14e4:4329) and came here by Google. Thanks for your help, maybe I could help you too.

I am using Kubuntu and Lubuntu (both 64bits), and spent some time trying to understand why the same card works fine in Kubuntu but don't exists in Lubuntu, both having bcmwl-kernel-source installed. Using lsmod as you suggest now I think seems that has a conflict because of many drivers installed.

I suggest you try:

  • run lsmod | grep "brcmsmac\|b43\|ssb\|bcma\|wl" to list installed drivers
  • for each drive, run sudo modprobe -r drivername to disable it; disable all of them
  • then run sudo modprobe wl to enable just one of them
0

sudo gedit /etc/modprobe.d/blacklist.conf

Add # in front of "blacklist bcm43xx". Then reboot.

This fixed the problem for me.

0

I have this solved in 2019!

  1. Remove all drivers.
  2. Install only:

    sudo apt-get install firmware-b43-installer b4cutter
    
  3. Run:

    nano /etc/modprobe.d/blacklist.conf
    

    Put # before the following:

    # replaced by b43 and ssb.
    #blacklist bcm43xx
    

Reboot. IT WORKS!

I also replaced grub with refind btw. MacBookAir 2.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.