When I booted up my newly installed Ubuntu 11.04, I discovered, to my dismay, that the backlight was off by default. The keyboard shortcut (which is Fn+F6 on my Acer Aspire 4736) for turning on the backlight doesn't seem to work. I have been trying to resolve this problem for the past 2 days now, but with no success. By the way, the backlight did work properly once or twice at random - but the problem again popped up as soon as I restarted my system.

Thanks for your suggestion Lekensteyn, but I tried it and it didn't work. Could you, or anyone else suggest something else? I have really become addicted to Ubuntu, and working on Windows seems unnatural to me now.

  • Try to press Only F6 (your brightness key). Go to power settings form system>preference or search and adjust brightness when in battery mode or AC mode – shantanu Jun 30 '11 at 20:16
  • 1
    Very weird, Fn + F6 toggles mine properly... Aspire 5738Z. – nickguletskii Jun 30 '11 at 20:40
  • aspire 7750: fn+f6 works as intended too. – Rinzwind Jul 1 '11 at 17:19

Here is a solution that worked for me on Ubuntu 11.10 based on http://lare-india.blogspot.com/2011/09/ubuntu-upgrade-caused-blank-screen-on.html

Boot your laptop into Ubuntu.

Connect an external monitor or sit with your back towards a sunny window so the sunlight helps to illuminate the screen (a flashlight can help too).

Press Ctrl+Alt+T to open a terminal and type:
sudo nano /etc/rc.local

You will be prompted for your root password, which was set when you performed the install. Type it in and hit Enter.

Press your down arrow key to move the cursor to the last line and hit Enter

Press your up arrow key once and type:
setpci -s 00:02.0 F4.b=00

Press Ctrl+O to save and Ctrl+X to exit.

Now back in the terminal type:
sudo nano /etc/default/grub

Find the line
and edit it to
GRUB_CMDLINE_LINUX_DEFAULT = "quiet splash acpi_osi = Linux"

Press Ctrl+O to save and Ctrl+X to exit.

Back in the terminal enter:
sudo update-grub2

Once it completes, enter:
sudo reboot

Your computer will reboot and when Ubuntu boots back up, you should be able to see the screen with no problems.

  • 1
    Can you explain the meaning of the commands you gave? – Scott Severance Oct 25 '11 at 8:53
  • I followed these instructions to a t, on my Acer 5736Z-4016, when I was having the same problem. Worked perfectly. Thanks a lot. :D – MikeVaughan Jan 22 '12 at 21:21
  • I followed the instructions in this answer and I can confirm that this works. I'm using an Acer Aspire 4736z. Thanks :) – Terence Ponce Apr 1 '12 at 5:47

I've experienced similar issues with another Acer notebook which was running Ubuntu from a Kubuntu 10.04 32b Live CD (for testing purposes). Before starting up, the backlight was fine. In a later stage, the backlight suddenly turned off.

Luckily, I can remember the commands from my head, so I pressed Ctrl + Alt + F1 to switch to a virtual console. Since I am already logged in on a Live CD I ran:

cat /sys/class/backlight/acpi_video0/max_brightness | sudo tee cat /sys/class/backlight/acpi_video0/brightness

Unfortunately, the backlight turned off again after switching back to the GUI using Ctrl + Alt + F7, so I created a script that should be run in the GUI:

echo 'cat /sys/class/backlight/acpi_video0/max_brightness | sudo tee cat /sys/class/backlight/acpi_video0/brightness' > lite

When switching back to the GUI, I pressed Ctrl + Alt + T to open a Terminal and run:

. lite

Now as long as I stayed in this GUI without switching to a virtual console and back, the backlight would be OK.

Configuring the backlight through /sys/class/backlight/acpi_video0/brightness is a workaround, perhaps there is already a bug report on Launchpad. Otherwise, you could put the above cat .... brightness command in a startup script which will workaround the problem for now.


I have an emachines e725 and every time my screen times out, or computer falls asleep, I have to reboot for it to come back on. The settings for my temporary fixes for /etc/rc.local and /etc/default/grub are below:

1) /etc/rc.local

#!/bin/sh -e
# rc.local
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
# In order to enable or disable this script just change the execution
# bits.
# By default this script does nothing.
setpci -s 00:02.0 F4.B=00
exit 0

2) /etc/default/grub

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

I've a solution. When this problem occurred to my HP laptop, I just turn on the emergency light (or torch) in front of the LCD, then everything was visible. Then I go to System Settings, in the Brightness option, I just increased the brightness seek-bar, then my LCD back-light worked, and every problem was solved, then save this setting.


if the above didn't work, use the same steps, except where it says to edit Grub put: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Worked for me, on HP 2000 Notebook PC

  • Welcome to Ask Ubuntu. Be advised that "the above" is subject to change. All answers are sorted by the numbers of votes they receive. So you might want to consider describing the answer you refer to more precisely. – MadMike Jan 23 '14 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.