I originally installed the dell b1160w printer on ubuntu 12.04. It worked as expected. A few months ago I upgraded to ubuntu 14.04 64 bit and now I can't get the printer to work. I looked at the driver information on the dell site. They have not updated their driver since 2013 so 12.04 is the latest version with a supported driver.

Is there a work around for this problem, like a generic driver that I can use or a way to install whatever printer interface ubuntu 12.04 was using?

I have a windows virtual box. I can get it to work through there, but it's inconvenient to pull up my virtual box and transfer the files over to it anytime I want to print.

  • Did you find a solution ? same problem here, can't get it to work over wifi. It's working with the usb cable though. – Mat Sep 5 '14 at 12:39
  • Finally doesn't work over usb cable, don't know why :/ Ended up setting up an Ubuntu 11.04 virtual box image. I downloaded it from here : sourceforge.net/projects/virtualboximage/files/Ubuntu%20Linux/… (user / passwd : ubuntu / reverse). I've set up a shared folder and I can print without too much trouble. – Mat Dec 24 '14 at 9:57

I installed the driver (B1160w_Linux_v1.04_Driver from the dell site) on a fresh 14.04 machine. The printer worked without a problem.

Hope that helps.

  • 2
    AU encourages high-quality answers. You're only offering a rough sketch of your solution. Can you please elaborate and describe it with more detail? Thanks. – David Foerster Oct 25 '14 at 22:42

I downloaded this 1.04 version and then installed it as follows using the Terminal. It seems to be working.

cd Downloads
gunzip B1160w_Linux_v1.04_Driver.tar.gz 
tar -xvf B1160w_Linux_v1.04_Driver.tar 
cd cdroot
cd Linux/
sudo ./install.sh
  • 1
    you can skip the gunzip command, when you use tar xzvf in the next command. The z flag for tar makes it piping through gzip automatically – Wayne_Yux Feb 4 '16 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.