I recently upgraded my computer from 12.02 LTS to 14.04 LTS, but experienced problems with launching Google Chrome and being able to use Rhythmbox. Rhythmbox asked if I wanted to install additional software, but the installation failed and returned this error message:

package tex-common 4.04 failed to install/upgrade: ErrorMessage: subprocess
installed post-installation script returned error exit status 1

I found this thread on launchpad about the bug:


which offered some suggestions about fixing the error, but the ones I have tried haven't worked for me.

First, I tried these commands (although I think rm /etc/texmf/ didn't work, I got an error message telling me it was a directory). This didn't seem to fix the error.

sudo apt-get remove --purge tex-common texlive-*
sudo rm /etc/texmf/
sudo apt-get install tex-common
sudo apt-get install texlive-base
sudo apt-get install texlive-latex-recommended

I then tried:

sudo apt-get purge tex-common
sudo -E do-release-upgrade -d
sudo -E apt-get -y install tex-common texlive-base texlive-latex-recommended

but again, it didn't seem to fix the problem.

Finally, I tried the last suggestion in the thread:

  • Uninstall everything to do with emacs and xemacs (I used synaptic package manager, to find what to remove and to completely remove)

    I didn't actually do this step because a.) I didn't know if I had any issues with emacs and xemacs, and b.) because I don't know how to use Synaptic to do uninstall only the emacs and xemacs stuff.

  • Uninstall tex-common and all texlive-* files and:

     sudo rm -rf /etc/texmf

    This time the command worked, which I assume is because this one removes the files in texmf, instead of the directory itself.

  • Remove all texlive files (if any) e.g.:

    sudo rm -rf /usr/local/texlive/2014    
    rm -rf ~/.texlive2014
  • Install emacs24 then auctex using synaptic package manager

  • Install tex-common using synaptic package manager

    Again, I didn't install emacs24 and auctex, and when it came to installing tex-common, I just tried:

    sudo apt-get install tex-common
  • Install texlive following the instructions on http://tug.org/texlive/ (Installation from dpkg or Ubuntu software centre or synaptic package manager don't work for me.)

  • Add paths to /etc/environment as suggested by the installation program earlier. That is, for the version I installed, to the end of the PATH line add :/usr/local/texlive/2014/bin/x86_64-linux just before the closing" and add 2 new lines


    (without the colon, the manpath to everything except tex will be broken)

    I think I understood how to do this section, although it's the first time I've ever tried to set a path. Also, based on another thread, I used i386-linux instead of x86_64-linux.

  • Edit /etc/manpath.config by adding line

    MANPATH_MAP    /usr/local/texlive/2014/bin/x86_64-linux    /usr/local/texlive/2014/texmf-dist/doc/man

    after the last MANPATH_MAP line that already exists.

Originally I wasn't able to edit the manpath.config file as it was read-only, so I had to open the file with sudo vim to edit it.

After going through all of these steps and restarting, the problem is now worse, as I have to go Ubuntu, with Linux 3.13.0-34-generic (recovery mode) for anything to work. Otherwise there will be no icons along the top of the screen (such as battery, network, etc.) and the icons in the toolbar will not respond.

Would anyone be able to help me with this? I don't really know enough about what I'm doing to know if I'm doing something stupid or not.

  • So in the end I just got annoyed, backed up my files, and did a complete reinstall of 14.04. It all seems to work now. – joeqesi Aug 20 '14 at 9:41

I had a similar problem after the upgrade, but a simple remove, reinstall, and then reinstall all the other tex packages seemed to fix things.

sudo apt-get remove tex-common
sudo apt-get install tex-common
sudo apt-get install texlive-*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.