2

I need GNU Make 4.0+ because of the new file function.

How can I install this on Ubuntu 12.04?

I tried the .deb, but it depends on libc6 2.17.

2

For folks like you I have just put a 64-bit amd deb of remake for Ubuntu 12.04. remake is GNU Make with some extensions. The specific version I used was 4.1.

| improve this answer | |
  • Thank you for remake, I'm going to try it out. Just letting you know that your package can not be installed at the same time as Ubuntu's make-4 package. dpkg: error processing archive /home/thomas/Downloads/remake_4.1+dbg1.0_amd64.deb (--install): trying to overwrite '/usr/include/gnumake.h', which is also in package make 4.0-8 – thomie Jun 18 '15 at 17:01
  • Does adding --replacefiles take care of this? I'm quite sure what the best way to handle this on the packing side is yet. – rocky Jun 18 '15 at 17:59
  • @rocky, any updates on this install. I just tried to install the file you linked to and I get the same error, that it is trying to overwrite gnumake.h. It doesn't seem like --replacefiles is even a valid option. – mikeazo Jan 18 '17 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.