0

I have just upgraded from 12.04 to 14.04. The upgrade process went off smoothly, only asked if I wanted to keep some old configs (which I did) and I restarted the computer when finished.

The computer is a HP Envy M6 (less than a year old) originally with Windows 8 which I completely nuked in favor of Ubuntu about five months ago. This install has worked almost flawlessly since it was done. There was a minor problem early on with something I can't remember now as it was resolved in an update.

However, after this update to 14.04.1 I do not now have any wireless connectivity. This is what I have tried so far.

  1. Restart the computer. No effect.
  2. I tried the pressing the wireless function key, also no effect either way. The light didn't even go out.
  3. I also tried disabling and reenabling networking from the menu at the top of the screen. The same, no effect.
  4. After googling I have tried lshw, this provided the clue:

Under *-pci:2 with the description: PCI bridge

*-network DISABLED
    description: Wireless interface
    product: RT3290 Wireless 802.11n 1T/1R PCIe
    ...
    bus info: pci@oooo:08:00.0
    ...
    configuration: broadcast=yes driver=rt2800pci driverversion=3.13.0-34-generic firmware=0.37 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
    resources: irq:17 memory:c1510000-c151ffff
    ...

Please note, since there is no network on the laptop, I have typed this out by hand. I have tried to include what I think might be relevant, if you need more detail please ask.

Further to this and after some googling I attempted to:

sudo iwlist wlan0 scanning (which resulted in)
wlan0    Interface doesn't support scanning : Network is down

and

sudo ifconfig wlan0 up (which resulted in)
SIOCSIFFLAGS: Input/Output Error

Most of the relevant information I've found seems to revolve around lshw and ifconfig (which fails badly for me.) Can anyone help me work out what to do here?

Thanks.

Update

Okay. Some new info.

Last night when I left, I suspended the laptop (as I usually do) rather than shutting down. When I came in and woke the computer this morning, the wireless was back up and working.

I have not tried restarting yet, I have a lot of work to do and don't want to spend time messing around with it quite yet.

1 Answer 1

0

Try this command as root:

ip link set wlan0 up

if it doesn't work then try this:

rfkill unblock all

If that also doesn't work then may be drivers for Wireless is not installed, you need to install it manually.

3
  • But it can work as Simple User too. I have tries and it works perfectly. But anyway thank you.
    – Novice
    Aug 18, 2014 at 8:55
  • Some time it happens that some of services don't get started properly at the time of Boot-up, but events like log-off, suspension or restart may be helpful. If you plug Projector to lappy, when Ubuntu is running, you need to log-off and again log-on then projection will go Live.
    – Novice
    Aug 19, 2014 at 5:17
  • Thanks. I'm guessing that something was put in the suspended state when the upgrade was done, and that it wasn't taken out of that state until the whole system was suspended and unsuspended. A restart merely restarted leaving the state unchanged.
    – John Judd
    Aug 19, 2014 at 5:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.