Prior to the upgrade, I could be on wikipedia and play the 'play' links fine where totem would open a window and have screen graphics go on. Now, after researching, installing VLC and it's extensions, making sure the gnome codec installer is activated, and on and on, all I get is : "The parameters passed to the application had an invalid format. Please file a bug!

The parameters were: --transient-for=16777296 gstreamer|1.0|totem-plugin-viewer|audio/x-midi-event decoder|decoder-audio/x-midi-event" When totem/video opens and I'm not sure whether the bug is being reported or not. Meaning I don't know if APPOrt is active for this as there's no box with a checkmark in it display.

AND the window for totem/video ALWAYS has the sound muted when it opens.

  • You can run ubuntu-bug packagename or ubuntu-bug -w and then click on the offending window. You can also run ubuntu-bug PID replacing the PID and/or packagename variable with the corresponding value. see here askubuntu.com/questions/5121/how-do-i-report-a-bug and here help.ubuntu.com/community/ReportingBugs on reporting bugs.
    – mchid
    Aug 18 '14 at 1:09
  • Also, sometimes you can run into trouble if you have conflicting plugins enabled like vlc and totem. If you have more than one running, disable one or the other.
    – mchid
    Aug 18 '14 at 1:14

Solution for Ubuntu 14:04 LTS

  • open Synaptic Package Manager;
  • type in search: fluidsynth;
  • install plugin vlc-plugin-fluidsynth;
  • enjoy.

There is no need to install VLC, because the totem alone works perfectly.

  • Could you please rewrite the question so it easyer tounderstand and read? At least to me it is hard to get. Sep 20 '14 at 6:03
  • That worked for me. Now I just VLC to be the predetermined program to open .mid files
    – Valentin
    Mar 25 '15 at 17:22
  • Totem did not play the MIDI file to me. VLC worked, though.
    – brandizzi
    May 26 '16 at 13:54
  • Wow dude nice find. Now both vlc and totem can play .midi files. I am 16.04 btw
    – smac89
    Nov 26 '17 at 22:27
  • To get Videos/Totem to play MIDIs, without needing to support VLC, all I had to install was the fluidsynth package. Mar 1 '18 at 16:26

I removed and then reinstalled VLC. Then scrolled down for the '41 other technical' at the bottom of the VLC install in Ubuntu Software Center and added "fluid-synth" to install. Resolved problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.