I use Acer 4530.

This problem has happened long since Ubuntu 10.10 and now that I use 11.04 dual booted with Linux Mint 10. Everytime I press one key repeatedly, like when I read a long article in a website/ebook or when I play games which required me to press arrow keys repeatedly, it would randomly freeze. That is, whatever I press on keyboard has no effect, and that also happens with touchpad. However, the USB mouse works just fine. I later found out that it's not actually freeze but more like it's like the key stuck. For example when I play tetris which I usually press w (down) button repeatedly, after some times it would freeze. And if I put the cursor in, say, browser's address bar, it would type "wwww....." infinitely.

The only way I could fix it is by suspend the laptop, either by using mouse or by closing the lid. And instead of suspended, in that case the laptop would automatically wake up and everything will be fine. (Usually my laptop would wake up after suspended by pressing any key)

It has happened since the first time I use Ubuntu, 10.10, and it also happens in Linux Mint 10, and until now in Ubuntu 11.04. It never happened when I use Windows, though. Anyone has ever encounter similar problem? Anyone know how to fix it permanently?


I just recently installed Windows 7 and Windows 8 Development Preview and both have similar symptoms. So I declare that this problem is not OS specific, probably hardware problem.

  • I wonder if we're all on the same page. I think what the original question was trying to explain is, that after the key is pressed and then released.. the letter of what ever key was pressed continues across the screen all on its own. Behaving like the key contacts are shorted together. this is what happens on my machine. Example: Say I press the letter 'K' once and release it, what I see on the screen forever and forever is...KKKKKK... Also I have to ask, what is meant by 'In Settings->universal access'? I can't find 'settings' or 'universal access' – user36658 Dec 5 '11 at 2:45
  • Yes I think we have similar problem. Although I now realize that sometimes it's not the same key. Sometimes it's not 'K', I just don't know what it is but my keyboard is still unresponsive. If you use newest Ubuntu if you click the upper left most button you'll get 'System Settings' you click it and there would be an item titled 'Universal Access' or just type in launcher 'universal' you'll find it. However it's not the solution. I've tried it. – Aziz Rahmad Dec 15 '11 at 15:13
  • I agree with your observation that it's not freezing, rather, the key is stuck. And yes, I remember it happening in Windows (Vista/7) too. But previously, it was only the non-character keys (e.g. arrows, ctrl, alt, shift, Win) but recently, all character keys are having the same problem too (thus resulting in keys like y repeating yyyyyyyyy even when not held). Usually the stuck key gets restored when I press it again. – syockit Nov 30 '13 at 1:47

Use the folling command in terminal to set the keyboard repeat rate and delay time to whatever works for you.

kbdrate [ -r rate ] [ -d delay ]

For example, use the following command if you want to set the repeat rate at 20 characters per second and 500 millisecond delay time.

sudo kbdrate -r 20 -d 500

Test out few other numbers for "-r" and "-d" to find values that work for you.

To make the values stick at every login:

gksudo gedit /etc/rc.local

And at the end of that file add:

kbdrate -r 20 -d 500

Save the file and restart your machine.


| improve this answer | |
  • I'm sorry for my lack of understanding, but when should I do this? Whenever the key got stuck? And how is this exactly fix the problem? – Aziz Rahmad Jul 2 '11 at 16:36
  • Once you find a kbdrate that works you need to add to the /etc/rc.local file for the settings to stick at every login. I edited my answer above. – 13east Jul 2 '11 at 17:14
  • Indeed, how does this fix the problem? Repeat rate may reduce the rate of damage, but the damage is still being done. Delays do not help too; once the key gets stuck, it will start repeating unless you press it again. – syockit Nov 30 '13 at 1:50

I had the same issue. I resolved it by turning off the bounce key feature. It's in setting-->universal access

| improve this answer | |

I also had the same issue, and this fixed it for me, but then you lose something too:

Settings → Keyboard → Turn off Repeat keys

Though now you can't hold a key for a bunch of letters, it should help.

| improve this answer | |
  • I turned off using xset r off in console, then I realized how much I was depending on arrow keys repeating :( – syockit Nov 30 '13 at 1:43

The problem lies in UNIVERSAL ACCESS --> TYPING The feature BOUNCE KEYS it is meant to ignore fast duplicate key presses.

Just turn it off and it will work perfect

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.