15

I'm having trouble getting audio through my TV which is connected via HDMI. The item is available (HDMI / DisplayPort 2) via sound settings, but it doesn't play any sound. I'm able to get the volume when logged in to Windows on the same setup.

I've tried updating my graphics card drivers through Software & Updates > Additional Drivers to NVIDIA binary driver - version 331.38 from nvidia-331-updates)

I've done a couple of the things listed here: Ubuntu refuses to output audio via HDMI (installed pavucontrol, did the sound test on the highest voted answer), but they seem to be related to not even seeing the device listed, whereas I have the device listed I just can't get any sound.

When I play through Speakers - Build-in Audio it works

  • Welcome to AskUbuntu! Could you list what program you are using to control your sound settings. (Not sure this will help, but more information is always nice) – No Time Aug 17 '14 at 19:44
  • Just System Settings > Sound – Tom Aug 17 '14 at 19:47
  • quick question: what kind of graphics card are you using?? Could it be a nvidia optimus card?? – Akisame Aug 24 '14 at 17:41
27
+50

Just fixed my audio issues spent days updating drivers and it ended up being the most basic setting. Permissions, add yourself to the "audio" group. So pop out to terminal and execute the following command.

sudo adduser $USER audio

Hope it works for you as well. It's odd that you are not automatically in that group as sound is an essential service.

Oh, and reboot, just to ensure the permission kicks in.

  • 1
    Well, that worked... and, agreed, very weird you wouldn't automatically be in the audio group. Thanks for the help. – Tom Aug 24 '14 at 20:56
  • 1
    Excellent, thank you! Although, you can improve slightly by using $USER so that people can just copy/paste the command. – Nicu Stiurca Nov 10 '15 at 20:08
  • sudo adduser $USER audio – gerardw May 11 '16 at 16:59
8

Try these steps:

  1. Install pavucontrol, if you haven't already, using the command:

    sudo apt-get install pavucontrol
    
  2. Add your username to the groups audio, pulse, pulse-access, video and voice using the following command:

    sudo usermod -a -G audio,pulse,pulse-access,video,voice $USER
    

    If the command gives you errors on groups that don't exist, just ignore it.

  3. Install the latest ALSA drivers using the following commands:

    sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily
    sudo apt-get update
    sudo apt-get install oem-audio-hda-daily-dkms
  4. Reboot and check if audio over HDMI is working.

Sources:

  • installing the alsa drivers caused my PC to kernel panic – Innocent Kithinji Oct 7 '17 at 20:02
1

I was having same problem voice is not coming in TV after HDMI cable. I changed my sound setting after that it works perfectly. I changed my default sound setting as shown in image speakers to HDMI.

:

Sound Setting

0

Try restart Puseaudio,

after the PulseAudio restart the device now displayed at configuration window.

See command:

pulseaudio -k

I added $USER to audio group too:

sudo adduser $USER audio

From: https://itsfoss.com/how-to-fix-no-sound-through-hdmi-in-external-monitor-in-ubuntu/

-1

This worked on a Dell Inspiron 3647 running Ubuntu Studio 14.04:

  1. Opened a terminal (Ctrl-Alt-T)

  2. Typed "alsamixer" at the prompt, then hit enter

  3. Hit F6 key, then chose another card from what was listed

  4. Tested the sound with a Burning Spear video on Youtube, and had sound

Hope this helps you.

  • what for those not having another sound card? – rancho Jun 18 '16 at 15:42
  • This is for a system with only 1 sound card: please try the solution verbatim. – jmasalle May 2 '17 at 4:40
-2

I have gone through the same headache [no sound out with HDMI] with my ACER Travelmate 8481G laptop with NVIDIA Optimus and Linux.

I tried every solution I could but because i installed a closed solution OpenELEC I was unable to try Bumblebee.

But then it occurred to me;

Bios change GPU from switchable to Discreet and Disable on-board audio

And this worked perfectly. NOTE: if you want to have sound come through the laptop speakers you will need to enable the audio when you are done with your HDMI.

  • I did it, but didn't work. Also why should it work? – rancho Jun 18 '16 at 15:43
  • disabling my NVidia GPU is less acceptable. – nyxee Jul 23 '16 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.