6

In 14.04, I notice that while composing Thunderbird has stopped wrapping text, and it is annoying to have to use to 'enter' to see the whole mail on screen without having to scroll horizontally!!

I don't know where to set wrap text after xx (72??) characters in Thunderbird

4 Answers 4

5

There is a place it can be set although I don't know why it would have been changed on you.

From the Thunderbird Menu, choose Edit->Preferences->Advanced->General->Config Editor

In the Config Editor, enter 'wrap' as a search term

I've enclosed a screenshot of my settings for this, which work and have not been changed that I know of.

enter image description here

5
  • Mine shows 72 here as well. I now discover that the first line of the mail being composed wraps after 72 ch. The second line onwards goes on and on...I have not counted to how many characters... Aug 17, 2014 at 19:25
  • After experimenting with the ADDON suggested above by @Tim, the firstline wrap has gone as well! Aug 17, 2014 at 19:49
  • I edited this to 78 just to see if it works. No! Aug 17, 2014 at 19:51
  • From editing Firefox before, if the settings in thunderbird are not default they should be bold - could you scan through the config to see if there is something changed from default? Aug 17, 2014 at 20:45
  • @ Charles Green when I changed it to 78, it was bold. Said User Set or something. Since it not solve the problem, I changed it back to 72. Now it is 'default' 'integer' and no longer bold. Aug 18, 2014 at 0:27
1

I don't think toggle wrap is an option in Thunderbird. Thee is however an extension, called Toggle Word Wrap:

Checking "Enable Word Wrap" will enable word wrapping again and set it to the standard width (which is modifiable through the "mailnews.wraplength" preference in the Config Editor, the default is 72 characters).

You can also disable it whenever you want, however I believe that is only temporary.

You can get it from the Addons site.

3
  • @ Tim...I installed this Addon, and it shows greyed under 'options' so, I am unable to set it. See my comment below the other answer, now even the first line fails to wrap :-(. Aug 17, 2014 at 19:40
  • I have now removed the extension.. now the first line wrapping that worked before is gone for good. Now auto text wrapping is not possible. Aug 17, 2014 at 19:48
  • Don't know, sorry it messed it up...
    – Tim
    Aug 17, 2014 at 20:20
1

1) Go to your Thunderbird profile folder

2) Make a directory named chrome

3) Inside the chrome folder make a file named userContent.css as a plain text file (be sure to show file extensions otherwise you may end up with a userContent.css.txt)

4) Edit the file with any text editor and put the following line in it:

* { word-wrap: break-word; }

5) Restart Thunderbird

3
  • FYI - Unlike Windows, Ubuntu (and all other *nix based OS's) don't use file extensions automatically and don't have an option to show or hide them. Correct me if I'm wrong.
    – Elder Geek
    Feb 19, 2015 at 21:15
  • Your wrong on the hiding part. I have Ubuntu 16.10 and on it and previous versions, Ctrl-H turns hiding on/off on Nautilus.
    – Dominic108
    Mar 20, 2017 at 1:02
  • This answer has been copied from here: superuser.com/a/709723/598527
    – user598527
    May 6 at 16:07
1

As Charles Green suggests, go to Edit->Preferences->Advanced->General->Config Editor and enter 'wrap' as a search term. There change plain_text.wrap_long_lines to true. This worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .