-1

I wanted to identify my wireless network interface name to check my wireless network card is installed properly or not . But i am getting something different.

I'm used to seeing this:

$ /sbin/iwconfig

wlan0     IEEE 802.11  Mode:Monitor  Frequency:2.437 GHz  Tx-Power=20 dBm

but I am now seeing this:

$ /sbin/iwconfig

eth0      no wireless extensions.

eth1      IEEE 802.11abg  ESSID:"REPALLE"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: C0:A0:BB:17:12:6E   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

lo        no wireless extensions.

Why is my wireless card showing up as an eth interface instead of a wifi or wlan interface, and how can I make it appear as I expect?

1
  • That's just a name... Does your wifi card work? Aug 17, 2014 at 12:49

1 Answer 1

0

The Broadcom wireless driver provided by bcmwl-kernel-source, as well as some older Intel drivers, names the wireless interface ethxy, where xy is the next available eth interface name. The driver does provide a parameter you may change. I have no Broadcom card so I've never tried this, so the process may or may not work as expected. In a terminal:

sudo -i
echo "options wl intf_name=wlan0"  > /etc/modprobe.d/bcmwl.conf
rm /etc/udev/rules.d/70-persistent-net.rules
exit

Reboot and your interface is probably wlan0.

13
  • Thanks chili555 my interface name is changed to wlan0 but still i am not getting the desired output :- wlan0 IEEE 802.11 Mode:Monitor Frequency:2.437 GHz Tx-Power=20 dBm
    – Trushar
    Aug 18, 2014 at 20:04
  • Is Network Manager set to Infrastructure mode? Or what? Does it help to do: sudo iwconfig wlan0 mode managed
    – chili555
    Aug 18, 2014 at 20:14
  • how can i set Network Manager set to Infrastructure mode? @chili555
    – Trushar
    Aug 18, 2014 at 20:23
  • Right-click the NM icon, select Edit Connections > Wireless > Edit > and change Mode to Infrastructure. Save and close.
    – chili555
    Aug 18, 2014 at 20:25
  • ya its in infrastucture mode.
    – Trushar
    Aug 18, 2014 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.