I am trying to connect my 64 bit Ubuntu 14.04 Dell Inspiron laptop to my Sony LCD TV with HDMI.

The video works, but the audio does not. It continues to give audio from the laptop, not from the TV. There is no problem with my TV as it used to work with another Dell laptop with Windows 7.

If i go to System settings -> Sound in Ubuntu, the HDMI device is not listed under output. But aplay -l command does list out HDMI sound cards :

faizal@faizal-Inspiron-3537:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Here is what all i have tried to resolve :

Based on https://askubuntu.com/a/117773/279330, i tried :

speaker-test -c 2 -r 48000 -D hw:0,3

The test was successfull and the HDMI is now listed in sound settings. But the audio still does not output from the TV.

Then i try the instructions at https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS i.e. I install DKMS, download the ALSA package and then run sudo dpkg -i <filename>. But i get the error during install :

Selecting previously unselected package oem-audio-hda-daily-dkms.
(Reading database ... 360224 files and directories currently installed.)
Preparing to unpack oem-audio-hda-daily-dkms_0.201408161316~ubuntu14.04.1_all.deb ...
Unpacking oem-audio-hda-daily-dkms (0.201408161316~ubuntu14.04.1) ...
dpkg: dependency problems prevent configuration of oem-audio-hda-daily-dkms:
 oem-audio-hda-daily-dkms depends on dkms (>= 1.95); however:
  Package dkms is not installed.

dpkg: error processing package oem-audio-hda-daily-dkms (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

Can i try something to fix this?


Solved! After the ALSA upgrade failed, i opened Software center. It showed me an error that some module is not right and gave me the option to repair it automatically. I did and then ran the install again(sudo dpkg -i filename). It worked this time. Restarted the system, chose HDMI output from sound settings and voila!

I think the problem was that i forgot to install DKMS initially(the error message makes it pretty clear). So Software center must have installed it for me during the repair.

  • 1
    Yes, the dpkg -i command does not resolve dependencies so, most of the time, when you run this command to install a package, you have to run sudo apt-get -f install after to install the necessary dependencies; software-center was smart enough to run that for you. – mchid Aug 17 '14 at 12:10
  • Also, you can accept your own answer by clicking the icon on the left to mark it as answered. – mchid Aug 17 '14 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.