4

Observation: if I hit Alt+F2 and enter compiz --replace, then the shorcut key Alt+F4 for closing windows stops working. I am using the latest version of gnome-ubuntu (14.04).

Question: Is there a way to restore the hotkey functionality? Or is there another way to restart compiz without losing the hotkey functionality? Also tell me, if this is a bug, then I'll try to report it! Also sometimes Ctrl+Ctrl/C/V stop working, but it seems to happen for a different reason which I have not found out yet. Therefore it would be nice to know how to restore/relaunch the keyboard functionality in general.

Unfortunately I have to restart compiz this way sometimes, because occasionally my mouse clicks will stop working (for whatever reason, but this is a different story), and the solution other people with the same problem have found is to restart compiz.

10
  • 4
    Does Ctrl+Q still work?
    – Tim
    Aug 17 '14 at 8:45
  • Take a look at the key configuration in ccsm: What is in "General options/Key bindings/Close window"? Aug 17 '14 at 9:16
  • 1
    @VolkerSiegel it says <Alt>F4 before and after. However, if change that value to something else, and change it back to <Alt>F4, then it starts working again.
    – Stan
    Aug 17 '14 at 9:46
  • 2
    Oh, that really feels like a conflict between two programs binding the <Alt>F4... Aug 17 '14 at 9:49
  • 1
    did you try resetting the profile in CCSM- Preferences? That should remove all the conflicts. One more thing, do you have two or more ccsm type managers running simultaneously? If yes- then remove one of them from the startup.
    – hunch
    Mar 17 '15 at 13:29
3

I believe this is a bug. Going into CCSM and toggling the Close Window key binding under General Options fixed it for me, but this is obviously not an ideal solution.

2
1

This behaviour also can happen with unity --replace.

One possible solution is to check in whether commands are enable in CompizConfig Settings Manager (you may need to install it with apt-get install compizconfig-settings-manager).

Look for an option called 'Commands', in the 'General' category. In my case this was un-checked. I suspect these settings may have been used when restarting Unity/Compiz, though that doesn't explain how Alt-F4 worked at first, after logging in.

I'm using the Unity edition of Ubuntu 15.04.

1

To restart both Compiz and Unity open the terminal and type:

setsid compiz --replace    
setsid unity  

After running these two commands the keyboard shortcuts will work normally (because of restarting Unity).

1
  • did not work for me on ubuntu 14.04. Neither alt f4 not control f4 work. Jan 5 '16 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.