2

I have a Dell Latitude with Ethernet and Wireless (broadcomm) adapters. They were both working fine on 12.04. I upgraded to 14.04.1 via the Software Manager. Since then I am unable to connect to the internet. Some info:

  • I can connect to my wireless router
  • I do get DHCP info from my router for both wireless and Ethernet
  • When I boot to a sysrescuecd (the current version), I get internet access on both Ethernet and wireless.
  • nm-tool shows me the same IP, prefix, gateway, and DNS in sysrescuecd as I get in Ubuntu.

Things I've tried: - I've tried setting the managed=true in the NetworkManager.conf file - tried setting the IPv6 to ignored (could not figure out how to disable it). - ping www.google.com fails (I think the error is 'unknown host' but I forgot to write it down)

Any help or would be GREATLY appreciated; my searching thus far has not seemed to find a universal cure (the last 'cure' I saw was a clean install of 14.04.1)

Thanks in advance.

** UPDATE ** AzkerM and Wild Man,

First off, thanks so much for your quick response - each time I use this forum, I am impressed by folks like you who are so willing.

I was able to resolve the issue - see below - but if someone could please tell me why it resolved the issue, I think I'll gain a better understanding.

I was able to solve my issue by running

sudo dhclient

I found that in the following question at askubuntu

Can someone please let me know why this would solve the issue?

  • 1
    Hi & welcome to AU. Could you please post the output for cat /etc/resolv.conf & ifconfig by editing your question. – AzkerM Aug 17 '14 at 2:14
  • Please run the script that is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…> – Wild Man Aug 17 '14 at 2:28
  • 1
    Glad you found the answer for yourself. You may post it as an answer since you found the solution. Well, I'm guessing that may be something had gone wrong with either the network config or the dhcp . Because when you run sudo dhclient will give you a notification as; XXXXXXX answers: File exists. May be your file got corrupted or didn't exist for some reason, or may be I'm wrong. :) – AzkerM Aug 17 '14 at 3:08
  • 1
    AskerM - how do I post as an answer - I see Up/Down tags, favorite tag, and this add comment - not sure how to post as an answer. Thanks again for all your help on this! – HockeyBum Aug 19 '14 at 13:02
3

I was able to solve my issue by running

sudo dhclient

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.