9

It's either not intuitive or not working in Ubuntu 14.04.

I want to mount my internal HDD at at startup (I boot from an SSD). I attempt to set this, following this procedure:

  1. Open Disks utility
  2. Select the disk
  3. Below the disk's Volumes, click on the More actions button
  4. Select Edit Mount Options...
  5. Select Automatic Mount Options "Off"
  6. Under Mount Options, ensure that Mount at startup is selected
  7. Click OK
  8. Enter password into Authenticate dialog box
  9. Restart

but this procedure doesn't work. Upon rebooting, and after Grub attempts to start Ubuntu, I receive the error message "An error occurred while mounting /mnt/4f721fc0-8072-453f-b48f-ca686bd89549. Press S to skip mounting or M for manual recovery". That identifier "4f721fc0-8072-453f-b48f-ca686bd89549" was automatically assigned by Ubuntu.

I press S and the boot process continues OK. If I try to mount the disk immediately after booting, I receive the error message "Unable to access "Storage"" (I named the volume Storage).

So then I start the Disks utility and set it to Automatic Mount Options "On" and reboot.

To me, it seems like this should work, but it doesn't.

Here are a number of photos of the process (Alt+PrtScn doesn't work after selecting More actions).

  • So even when you turn Automatic Mount Options On, still won't work? – Mitch Aug 17 '14 at 2:33
  • I turned Automatic Mount Options off in step 5. I got an error when I rebooted so I turned it on again and rebooted, and it works, but I need to mount it myself when the computer has finished booting. It doesn't mount by itself at startup, which causes problems for any startup applications that look for that disk.. – el_gallo_azul Aug 17 '14 at 8:02
  • Worked ok for me. I didn't turn off Automatic Mount options and after exiting, I pressed the mount button and mount happened with no problems. – steven smith May 22 '18 at 6:32
2

Yes I finally did this (successfully, it seems so far) by editing fstab.

I would have preferred if it had worked after I tried the intuitive method in the Disks utility.

The process:

  • Google search "ubuntu 14.04 mount internal hdd at startup"
  • Open and read

http://ubuntuforums.org/showthread.php?t=1571781&page=2 and

http://ubuntuforums.org/showthread.php?t=1571781&page=3 and

http://ubuntuforums.org/showthread.php?t=1571781&page=4 and

Unable to mount hard-disk at startup and

problem mounting second harddrive with ubuntu 14.04 and

How do I get my internal HDD to mount at startup? and

https://help.ubuntu.com/community/Fstab and

http://ubuntuforums.org/showthread.php?t=283131 and

https://help.ubuntu.com/community/AutomaticallyMountPartitions#Per-User_Mounts

  • Go to /etc/fstab file
  • Right-click on file and run Script 'open-as-administrator'
  • Add
# mount 4f721fc0-8072-453f-b48f-ca686bd89549/sdb1/Storage at boot
UUID=4f721fc0-8072-453f-b48f-ca686bd89549 /media/el_gallo_azul/Storage ext4    defaults 0       2
  • Test by rebooting
  • Determined to be successful by Dropbox not showing 'Dropbox folder not found' error message that it had always shown at the end of booting previously.

I'm now one step closer to getting BOINC to use my internal HDD instead of my SSD for its data directory. I'll keep chipping away until I achieve it.

By the way, I had a little look in the Disks utility settings after I did this, and indeed the settings were exactly the same as what I tried to set via the intuitive method.

  • Looking at it now, it looks like the error with my original intuive method was that Ubuntu tried to mount the partition straight to /mnt/ afterwards, whereas my manually edited fstab mounted it to /media/el_gallo_azul/Storage. – el_gallo_azul Oct 25 '14 at 3:52
  • I was wrong, because that mount point wasn't causing the error. It did mount at /media/el_gallo_azul/Storage, but I've since had to mount it at startup to /mnt/... instead of at /media/... in order to maintain the permissions as I want them. – el_gallo_azul Dec 13 '14 at 2:45
  • note you don't have to reboot to test. just use mount -a YMMV and you may need to sudo to do it. serverfault.com/a/174182 – engineerDave May 4 '18 at 0:50
2

You can try checking up /etc/fstab file with sudo -H gedit /etc/fstab. Here's some more help about fstab.

It's also good idea to back up this file before changing.

2

I was trying Sudheer's suggestion today. I tried all the different Identify As options to no avail, as every reboot showed that it wasn't working correctly.

What was happening was that the drive itself was mounting correctly, but all the bookmarks were broken (Folders with Yellow on the left panel), therefore I was lead to believe that the drive was not mounting at all.

enter image description here

Then I realised my mistake and found out that when you select an Identify As option, it will set the the Mount Point to a default value (e.g. /mnt/[uu_id]).

enter image description here

This is not the mounting point I desired (e.g /media/[username]/[MountFolderName]) and it was incompatible with the bookmarks I have set on the Files Application.

So you need to set the Identify As option first, then set the Mount Point to your desired location. I basically fell in the same trap as user el_gallo_azul above, but I was lucky enough to finally spot the missing step required.

enter image description here

So the Disks utility definitely can automount and you shouldn't have to modify fstab.

I'm using Ubuntu 18.04 with a front end skin (POP O/S 18.10)

0

Try changing "Identify As" to LABEL option.

enter image description here

  • 1
    I don't understand. By default, this internal HDD has Automatic Mount Options "On". My understanding is that I want to deactivate Automatic Mount, and have the disk always mounted at startup. The internal HDD is currently mounted only when I select the disk in Nautilus, and it remains mounted from that moment until I unmount it or shutdown. Note that I interpret your word "automount" as meaning Automatic Mount. This issue seems like a bug to me. I select the option "On", and then it causes an error when I boot, so I have to turn it back "Off" again. – el_gallo_azul Aug 24 '14 at 0:45
  • When you on Automatic Mount Options what error you are getting. – Sudheer Aug 24 '14 at 2:32
  • 1
    The commands id -u and id -g output the UID and GID respectively. – muru Aug 24 '14 at 2:38
  • @Sudheer I described exactly what happens (when I try to mount my internal HDD at startup) in my original post (above). – el_gallo_azul Aug 24 '14 at 5:46
  • 1
    I saw @Sudheer suggestion today "Try changing "Identify As" to LABEL option". I thought that sounded worth trying, so I did try it (an extra step just after Step 6 from my original post) but the result was exactly the same. ie. It didn't work. – el_gallo_azul Aug 29 '14 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.