6

I have the following problem: when scaling a window to the bottom of the screen, it gets automatically maximised vertically. This is very annoying as I want to decide how to scale my windows!

I found no option that triggers this.

The compiz plugin grid is disabled. Everything I find when searching for my problem, are references to grid ...

My System:

Ubuntu 14.04.1 LTS

Kernel 3.13.0-32-generic

Compiz 0.9.11.2

Gnome 3.8+4ubuntu3

Using Gnome Fallback Mode

  • What is scaling a window to the bottom of the screen? – Tim Aug 16 '14 at 20:18
  • Pull the bottom border of a window down, until you reach the bottom of your screen – Nicolas Aug 17 '14 at 0:53
  • Doesn't happen to me - gnome 3.12 – Tim Aug 17 '14 at 8:17
  • Thank you Tim, your information helped me narrowing down the root cause, as on my system logged in with standard gnome (or gnome fallback with metacity) the described behaviour did not occurred as well! This directly pushed me into the direction of compiz. – Nicolas Aug 18 '14 at 20:49
5

Ok, finally found the reason for the automatic window maximising: the compiz resize plugin!

The settings for this plugin contain an option called Maximize Vertically if screen edge hit in the tab General. This did the trick.

Though I checked each compiz plugin within the windows scope a thousand times before, I did not found this checkbox earlier. This is because I searched for a setting of type active screen edge and not of type checkbox.

Compiz resize plugin settings

Note: due to the lack of this information within the compiz plugin settings, I guessed the underlying name of this plugin being resize!

The german localized title is "Fenster skalieren aktivieren" which - directly translated - should be s. th. like "Activate Window Scaling" or "Activate Window Resizing". There is another plugin called "Skalieren" from which I assume, it corresponds to the underlying "scale" plugin, so "resize" should be the right one.

If anyone can confirm or correct this, I will edit my answer.


Update 2016-07-13

The "CompizConfig Einstellungs-Manager" is the "CompizConfig Settings Manager" and used to adjust all parameters of "compiz".

It may not be preinstalled on your system!

Check this by opening a terminal and enter ccsm.

If this command is not found, you can install it with:

sudo apt-get install compizconfig-settings-manager

Note: this install package name was changed somewhen in the past - if you have a really old system it may be named ccsm as well, if I remember this correctly.

| improve this answer | |
2

I find the same setting on my Ubuntu 14.04 and confirm it works too.

Since Nicolas' screenshot is not completely English, here are my steps to find it: CompizConfig Setting Manager-> Window Management -> Resize window -> General (Tab).

For the folks don't have CompizConfig Settings Manager installed, it could be found at: https://apps.ubuntu.com/cat/applications/compizconfig-settings-manager/

| improve this answer | |
0

You may find conflicts in CCSM between 'Window Management' plugins.

I wanted to stop the window filling the top half of the screen when I took it to the top edge. The behaviour seems to be determined by Grid and Maximumize. I found that even if I unticked: 'Maximumise' 'maximumize to up' and set 'Grid' 'Corners/Edges' 'Top Edge = None' it still half fills the screen when I hit the top edge.

However if I disable the plugin 'Maximumize' it ceases this irritating behaviour.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.