1

The last entries/queries I can find about PS3 dual shock controller are dealing with older kernel versions. It looks like there may still be a problem with using the PS3 dual shock via USB(or bluetooth) with 14.04? I'm only guessing because I get no sign of detection or input when I plug in the USB. When I run

dmesg | grep sony

[ 4687.762302] sony 0003:054C:0268.0003: can't set operational mode
[ 4687.770639] sony: probe of 0003:054C:0268.0003 failed with error -38

So at this point, I don't know if it's worth running : sudo apt-get install xboxdrv

I also found this article LINK but it's dated 01/2013.

I was considering installing steam, and checking out some of the games. There are a few in particular I want to check out, but I'm afraid of purchasing them and then my controller does not work. I don't have a ps3, I just have the controller for Sixaxis/emulator/Android set up...

I see mentions for QTsixa and xboxdrv and known bugs, but the posts are at least a year old(older distibution/kernels) So I'm wondering if the current Kernel has fixed the bug. Ideally, I'd like to just plug in USB, and play. No Bluetooth available right now..

0

Install sixad : sudo apt-get install sixad (Note that this only works via bluetooth. Well, you can use it via USB but then rumble and the LEDs won't work so I'd recommend sticking with bluetooth. You can still plug it into the USB port while you're using it as long as bluetooth is enabled).

Start sixad with : sixad -start

To restore regular bluetooth, stop sixad : sixad --stop and restore bluetooth : sixad --restore

I just tried this out a couple days ago, and I can confirm that it does work on the very latest kernel and Ubuntu 14.04.1.

You might need to adjust your bluetooth settings to get it to detect your controller.

  • Ok, I did not get a notification in inbox of your answer, so sorry for delay. I don't have bluetooth on this tower. Since I sit right next to it, and my controller's USB cable is plenty lengthy, I would be fine with just plugged into USB. Have you tried just controlling via usb, without installing Sixad or bluetooth enabled? You can still plug it into the USB port while you're using it as long as bluetooth is enabled Thanks – 5th Wheel Aug 18 '14 at 22:07
  • If you don't use bluetooth, you won't be able to use rumble. – Pranav Marathe Aug 18 '14 at 22:53
  • That's Ok, at least for now. I just want to try it out. I just figured since I had this control sitting here, maybe I'd check out steam, if it was compatible. So I looked ubuntu forums and saw that it used to work, but with fresh 14.04 it was broken. I'm not much of a gamer, so before I loaded up my system with a bunch of installs, I figured I'd see if other people had success with usb at least. – 5th Wheel Aug 18 '14 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.