2

I have Ubuntu 14.04 and problem with Mobile Internet (Huawei USB-stick). When stick is plugged in upper left USB slot, everything works fine, when is plugged in any of two slots in lower right - not working at all. At first I thought that device can not be recognized, but Ubuntu recognize it clearly, how do I set modem on?

When in first USB slot:

my.comp@Skynet:~$ lsusb
...
Bus 003 Device 006: ID 12d1:1c08 Huawei Technologies Co., Ltd.
...

When in second USB slot:

my.comp@Skynet:~$ lsusb
...
Bus 003 Device 007: ID 12d1:1c0b Huawei Technologies Co., Ltd. E173s
3G broadband stick (modem off)
...

I hope that this is not duplicate question, I've red (and tried) most of the solutions posted here, none worked

3

Here's what I did based on this description:

  1. Plug the USB device
  2. Open a terminal, run lsusb:

    Bus 001 Device 008: ID 12d1:1c05 Huawei Technologies Co., Ltd. E173s 3G broadband stick (modem off)
    
  3. Create a file /etc/usb_modeswitch.d/12d1:1c05

  4. Paste this content:

    ########################################################
    # Huawei E173s
    
    DefaultVendor= 0x12d1
    DefaultProduct= 0x1c0b
    
    TargetVendor= 0x12d1
    TargetProduct= 0x1c05
    
    CheckSuccess=20
    
    MessageEndpoint= 0x0f
    MessageContent=
    "55534243123456780000000000000011062000000100000000000000000000"
    
  5. Add corresponding lines to /lib/udev/rules.d/40-usb_modeswitch.rules with sudo gedit /lib/udev/rules.d/40-usb_modeswitch.rules:

    # Huawei E173s
    ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1c05", RUN+="/usr/sbin/usb_modeswitch -c /etc/usb_modeswitch.d/12d1:1c05"
    
  6. gksudo gedit /etc/modules, and add this:

    # manual override for Huawei E173s to work
    usbserial vendor=0x12d1 product=0x1c05
    
  7. Unplug and plug the USB device type lsusb. Now it should be modem on:

    Bus 001 Device 008: ID 12d1:1c05 Huawei Technologies Co., Ltd. E173s 3G broadband stick (modem on)
    

    Now you should be good to go and able to connect via the GUI:

    Ubuntu Gnome 14.04 Connect To Mobile Broadband

In case it's still not working, refer to the further steps described here: http://metodiew.com/huawei-e173s-and-ubuntu/

Note:

Your device id may vary 0x1c0b or 0x1c05 (or even something else)

1

I can't know too much about the situation based on your provided information but my barely-educated guess is that only your "top-left" USB port is a host and as such, the other ports can't fully power the dongle. I only say this because you said that "everything works fine" when it is in that "top-left" port.

[edit]Addendum: If it is indeed a USB-host issue then there is no solve, beyond new hardware. However, I was not satisfied in my assumption that USB-host issues are what's holding you back so I did some digging and found someone who had similar issues on on Debian and ARM architecture. They did manage to get it working and it is detailed here: http://jas-hacks.blogspot.ca/2012/10/hackberry-a10-3g-modem-support.html .. I do not recommend just diving in and doing exactly the same things, at least not without sufficient research into each process.

I have also found a few bug reports related to this, one of which was marked 'invalid' but had some potentially useful insight - and the other is marked as fixed. Both seem to indicate a problem with 'modemmanager' or 'usb_modeswitch" and the invalid one mentioned a script for connectivity on the device but I don't know anything specific about it. Invalid bug report: https://bugs.launchpad.net/ubuntu/+bug/993473

Fixed bug report: https://bugs.launchpad.net/ubuntu/+source/modemmanager/+bug/1057186

Finally, there is a post on the usb_modeswitch forum detailing similar problems, after an Ubuntu update with both temporary and permanent potential fixes: http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=960

I'm sorry I don't have a ton of expertise on this subject but I feel these various pieces of literature might get you pointed in the right direction.

  • Hi @Jagardi, thank you for reaction, but how to solve "(modem off)" – Ladislav Naďo Aug 16 '14 at 11:04
  • 1
    I've edited my answer to include a bit more information. I feel like the first link I posted might be the worst of my references and that the last link I posted, at the usb_modeswitch forum would be the best place to look, from what I've offered up. Best of luck. Hopefully someone with more concrete knowledge can assist you if you hit another wall. – Jagarti Aug 16 '14 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.