1

Watching video content on any website (YouTube, news sites, TV sites etc) the picture is slow/choppy, not at all smooth. The sound is fine. I'm mainly using Chrome, which has the latest Flash enabled. The same issue occurs in Firefox.

When I use Chrome (synched) in my XP partition all video is good and plays normally.

I'm on a Dell 620M with Intel Core 2, 1.83GHz, Ubuntu 14.04 (new user of Linux); 2GB memory, 66GB Ubuntu partition. Driver in Ubuntu is Nouveau display from X.Org (should I change to a Nvidia driver as they're the ones offered in the additional driver list?). CPU runs high since installing Ubuntu, around 50-60% for both processors; in XP it's very low, ~0-5%, even with several Chrome tabs open as well as IE.

At some stage the video on Chrome (on Ubuntu system) started working normally, but I'd tried so many things recommended all over the place that I had no idea what had solved the issue, and it didn't seem to matter given that it was working. Then after booting the next day the issue reappeared. At no stage has the choppiness of videos on Firefox improved. YouTube videos are using HTML, and are choppy also.

I've tried doing most of the things I remember doing yesterday: enabling and disabling Flash, clearing cache, reopening browsers, disabling hardware acceleration (not an option anymore), installed hal already, reinstalled ubuntu-restricted extras. (I'm unable to find what websites I visited yesterday as I deleted my browsing history.)

I'm unable to watch protected content on Chrome in spite of trying various fixes. I can watch it in Firefox but it's choppy.

Thank you very much for any suggestions (especially simple or detailed ones).

Update: I've switched to the recommended proprietary driver, Nvidia 304, but there's no improvement in video playing or the overall slowness of my machine with Ubuntu.

I don't know what this means, below, but does it offer any insight as to why my machine is running slow and videos playing laggy?

~$ /usr/lib/nux/unity_support_test -p  
Xlib:  extension "NV-GLX" missing on display ":0".  
OpenGL vendor string:   nouveau  
OpenGL renderer string: Gallium 0.4 on NV46  
OpenGL version string:  1.4 (2.1 Mesa 10.1.3)  

Not software rendered:    yes  
Not blacklisted:          no  
GLX fbconfig:             yes  
GLX texture from pixmap:  yes  
GL npot or rect textures: yes  
GL vertex program:        yes  
GL fragment program:      yes  
GL vertex buffer object:  no  
GL framebuffer object:    yes  
GL version is 1.4+:       yes  

Unity 3D supported:       no  
  • Just aside note: on youtube you may see with "right click on video->information" is the video in software rendering, or hardware. – Hi-Angel Aug 18 '14 at 1:36
  • Youtube is using HTML5 (mentioned in question), is this what you mean? I've been back using XP lately because of this video issue, and my machine runs real slow with Ubuntu. Thanks – Sky Aug 21 '14 at 21:17
  • Youtube is using both html5 and flash. I meant flash. If you go to YT via Chrome(and perhaps Chromium), it will be using html5. But for FireFox for some reason YT uses by default flash player. I guess you can somehow switch between both versions of site, but I dunno how. Offtop: I just some days before found the Compose key — it is just awesome, as you just switched to GNU/Linux from Windows, you definitely should try it. – Hi-Angel Aug 22 '14 at 0:52
  • Tbh, I had before a problems with a flash too. And mostly on FireFox. After a while a video became okay, I guess it was some perfomance update. But by my sorrow, when I was suffered of this, I didn't found, how to force flash work. I even tried replace flash player with another one — I wonder why a browsers didn't use anything else, as Adobe Flash widely known with a problems. But without success (I meant that I couldn't did it, you might be more lucky). If you're curious, right now the youtube information in my FireFox still shows «software rendering» – Hi-Angel Aug 22 '14 at 1:05
  • Sky try to install the shumway. It is FOSS alternative to Adobe Flash. I am for a curiousity installed it, and disabled the Adobe Flash plugin. But alas, as for me, I didn't noticed any change at all — as I said the flash video haven't been choppy for me for a while. – Hi-Angel Sep 13 '14 at 12:48
0

The solution was to install and switch to the Xfce desktop interface. It uses much less RAM than the standard Ubuntu 14.04 desktop interface (Unity), but can still be personalised and made attractive. When I log in I still have the option of using the standard Ubuntu set up, but it makes my old laptop too laggy to bother with so I always log into Xfce instead. Videos play fine now.

sudo apt-get install xubuntu-desktop OR sudo apt-get install xfce4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.