0

I've successfully installed Debian in my VirtualBox on Windows 8.1, but I wished to have Ubuntu. My machine is HP Envy with Intel i7 and 8GB RAM, NVidia GeForce GT 750M.

First strange thing I encountered is that the VirtualBox does not offer 64-bit Linux OS type alternative (and I actually was not able to run 64-bit Debian either). I've installed Ubuntu 14.04.1 32-bit. All I saw is a blank desktop.

I've read quite a bit on the issue and tried things. For example I updated NVidia drivers and enabled the Unity plug-in by the ccsm. But after I enter my login I still see a blank desktop and cannot even envoke a terminal with Ctrl-Alt-T.

dmesg reveals the following:

nvidia: module license 'NVIDIA' taints kernel.

nvidia: module verification failed: signature and/or required key missing - tainting kernel

NVRM: No NVIDIA Graphics adapter found!

Any ideas how to troubleshoot?

  • Are you running Ubuntu in a VM or as the host? If in a VM, why are you installing nvidia drivers in the VM? – muru Aug 16 '14 at 7:34
  • I'm running Ubuntu in a VM. I was (and am) wondering at which level virtualization is implemented. In my view it must be on the HW/FW level. Otherwise why is it configured in BIOS? A VM should not be using Windows drivers for virtualization. This (probably naive) thinking prompted me to even care of the NVidia drivers on Ubuntu. This however did not help:( – etxmsol Aug 16 '14 at 13:14
  • 1
    There are virtualization capabilities (which make VMs a lot faster) in modern CPUs. That's why it's configured in the BIOS (whether you enable these capabilities or not - if you don't you get the slower, pure software virtualization). However, this does not extend to the graphics card. I think if you disabled VT-X in BIOS, VirtualBox doesn't allow 64-bit guest. Have you disabled it? – muru Aug 16 '14 at 13:54
  • Thanks a lot for the hint! I enabled Virtualization Technology in BIOS and was later able to install 64 bit Ubuntu. 64-bit Ubuntu has a full functioning desktop from the beginning. The 32-bit version still has blank display, but this is not a prio issue for me any more. – etxmsol Aug 17 '14 at 7:05
  • @etxmsol If you consider this problem solved, I recommend posting your solution as an answer. – Eliah Kagan Aug 19 '14 at 0:54
1

Thanks a lot for the hint muru! I enabled Virtualization Technology in BIOS and was later able to install 64 bit Ubuntu. Obviously this option, disabled by default, made VirtualBox stick with 32-bit versions only. The 64-bit Ubuntu has a full functioning desktop from the beginning. The 32-bit version still has blank display, but this is not of much importance to me any more.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.