2

This question already has an answer here:

I'm sort of new to linux and I'm having a problem, I'm trying to prevent users from changing the desktop wallpaper (as well as other things but that is the main one)

I know this has been asked before but none of the current topics helped me and I've been at this for more than a week, They are also kind of old topics.

My configuration is: I installed Edubuntu 14.04, installed gnome (only using gnome for gconf and dconf to get this working, is there a way without gnome?) Have admin account, a standard account and a guest account, Wanting to lock down features on the standard account.

I've already tried doing it in gconf, dconf and using gsettings.

I don't want to use a guest account

I've been trying to use gconf and dconf but it's just not making sense to me, right now I'm trying it in dconf because I couldnt get it to work in gconf, I tried setting it as mandatory and default in gconf but it didnt work (I read that gconf isn't used in the newer versions of Ubuntu in favor of dconf, so that's why I'm trying dconf), right now I'm trying to do this in dconf again (the wallpaper part)

I'm under the impression that I'm supposed to create a file and put all the info they provide in there, like create the user name/database, then the keyfile (how do I make it a .d file?), then dconf update file, right? How do you get it to run after all that? Do I use a text editor like gedit? I tried going to the directory they said to and nothing is there and I wasn't able to make any new files or directory's in the GUI, and I can't move a file into there. Can you only do that through the terminal?

It would be great if i could restrict it to only the Admin able to change settings so I tried this:

chmod 744 /usr/bin/gnome-appearance-properties

But, I'm getting: chmod: cannot access 'usr/bin/gnome-appearance-properties': No such file or directory

when I try that.

and I would rather not use this, where you put this in the startup applications: gsettings set org.gnome.desktop.background picture-uri "file:///usr/share/backgrounds/edubuntu_default.png"

I've seriously tried all the help topics on the forum about this and many other web sites. Please help!

Thanks!

marked as duplicate by Eliah Kagan, Sylvain Pineau, Eric Carvalho, αғsнιη, psusi Oct 10 '14 at 15:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.