1

I have hardware "volume up" and "volume down" on my Lenovo Thinkpad W530. They used to work to increase and decrease volume. A day or two ago, they stopped working. xev sees them, in settings>keyboard>shortcuts, they are correctly assigned, I can assign other key combinations to change volume and that works, I can also assign the hardware keys to different actions and that does not work. It works for a guest account. Reboot does not help. I am at a loss what might be causing it. Any ideas where to look for causes? This is on 14.04.

  • Oddly enough, they work in mpv (but only change the internal mpv volume setting). And they also work in vlc. – sup Aug 15 '14 at 21:46
1

I had exactly the same symptoms with 14.04.

I imagined that VLC had 'grabbed' the media keys so I removed VLC. The problem persisted ...

I followed a reset suggestion that I found on the web:

Open a terminal and enter,

 gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up
 gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute
 gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down

This didn't seem to have any effect (which is why I closed the page and lost the link!). So I reinstalled VLC. But the next time I used an audio application I discovered that the media keys were working.

Maybe it was just luck and the keys will stop working again, but for now I'm a happy bunny :-)

  • Can you add the source to those commands please? – Kaz Wolfe Aug 28 '14 at 20:44
  • 'Fraid that I lost the link when it didn't seem to fix the problem straight away. – user321476 Aug 28 '14 at 20:48
  • Well, the commands can be found in the bug I linked in my answer. It indeed fixes the problem. – sup Aug 29 '14 at 0:06
  • Yeah, this is what happens. Expect it to randomly not work after rebooting. – doug65536 Apr 6 '16 at 8:39
0

Turns out this is a known bug.

0

Go to

keyboard>shortcuts>sound and media>

Then, redefine volume shortcuts (using those volume keys of your keyboard)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.