I've noticed that a lot of people have asked this before, but no method that I've found seemed to work, so I apologize in advance.

I've created a custom Live USB using the Ubuntu Customization Kit and a stock image of Ubuntu Desktop 14.04 64-bit. The reason for creating the custom image is because I would like a lot of the tools that I use regularly (Qt, ADT, build-essential, etc) to already be available instead of having to download 1GB+ every time I'm somewhere without my regular machine.

I'm using YUMI to create by bootable USB flash drive, which works great for the stock image.

Whenever I try to load ANY customized ISO via USB generated by UCK, it gives the error message:

(initramfs) unable to find a medium containing a live file system

However, when I burn the ISO to a DVD, it boots without a problem.

I've edited the isolinux.cfg to put 'vmlinuz.efi' at the end of live-media-path, thinking that might be it. I've tried to find information about where Ubuntu looks for the UUID of the device, only found it in the 'casper-uuid-generic' file.

Anyone have any ideas? Thanks for any help!


3 Answers 3


I was having the same issue and found that the fix was alarmingly simple (as is often the case). Edit the append line in your syslinux.cfg (or isolinux.cfg) file that is taking the parameters and simply add in ignore_uuid as a parameter. This fixed the issue for me, hope it's of some help to others.

Found a list of parameters here.


I just had this happen today. I used to run this method of installing Ubuntu 14.04 on my desktop 6 months ago, so I know it works. I use Rufus to create my Ubuntu 14.04 USB flash drive. I powered on my desktop and booted from the USB 3.0 flash drive connected to a USB 3.0 port. I get the Ubuntu logo screen with progress dots, then it gives me a black screen with the Busy Box prompt and error message. It's not the USB port choice like some posts suggest and I didn't need to run any commands to find broken superblocks. How could something install and run 6 months ago all of a sudden change? Then it hit me. Data Integrity. I simply used another USB flash drive with the same ISO. It was a success.


I was experiencing the same problem, here is what i did, first i opened ubuntu 14.04 in UCK, and locked the kernel version. Then i installed all the other updates and clicked "build". Using unetbootin i created bootable usb and i confirmed that it works properly. I customised this iso with my favourite applications. Earlier i tried to correct the errors shown in terminal while updating the kernels (there were errors in some scripts but fixing them did not solve the problem of -initramfs unable to find a medium containing a live file system” on custom Live USB?- then i decided to disable kernel update. hope this helps. i failed to find any other solutions for this.

Not the answer you're looking for? Browse other questions tagged or ask your own question.