Current status:

Cannot boot from HD at all (dualboot with win7)
Cannot boot from USB either (12.04 and win7), goes to boot: prompt, do not know what to do here, wants a kernel name, same for both Ubuntu 12 and Win7 usb drives.

At grub rescue prompt:

grub rescue> ls
(hd0) (hd0,msdos5) (hd0,msdos3) (hd0,msdos2) (hd0,msdos1)
grub rescue> ls (hd0,msdos5)/boot/grub/i386-pc
*bunch of mod files*
grub rescue> set prefix=(hd0,msdos5)/boot/grub/i386-pc
grub rescue> set root=(hd0,msdos5)/
grub rescue> insmod normal
error: symbol not found: 'grub_divmod64'.
grub rescue> insmod linux
error: symbol not found: 'grub_realidt'.

These errors were not part of the instructions I found while googling and googling the errors have not led to solutions. I'm pretty novice with Ubuntu/Linux/Unix. I'm guessing the MBR is messed up or boot.ini is missing or i dunno.

  • Thank you, boot repair works really good after upgrading from 12.04 to 14.04! (booted with live cd and then installed)
    – user241376
    Oct 4, 2014 at 8:00

3 Answers 3


I had the same situation. It appears that the grub that is booted is obsolete and can't load the required modules. I tried many things, none of them worked. In my case, I saw

(hd0) (hd0,msdos2) (hd0,msdos1)

The msdos2 had grub directory in it and modules in /grub/i386-pc, but I could not insmod anything really. It was giving me all sorts of errors, including error: symbol not found: 'grub_realidt'..

In the end, I attached an Ubuntu 14.04 CD to it, booted from CD, entered Rescue mode (I believe it says something like 'Repair a broken system') and chose the option to reinstall GRUB. That worked the first time.


Repair solve your problem.

1st option : get a disk including Boot-Repair

The easiest way to use Boot-Repair is to burn one of the following disks and boot on it.

Boot-Repair-Disk is a disk starting Boot-Repair automatically.

Boot-Repair is also included in Linux-Secure-Remix. 

Remark : you can also install the ISO on a live-USB (eg via UnetBootin or LiliUSB or Universal USB Installer).

2nd option : install Boot-Repair in Ubuntu

  • either from an Ubuntu live-session (boot your computer on a Ubuntu live-CD or live-USB then choose "Try Ubuntu") or from your installed Ubuntu session (if you can access it)

  • connect to the Internet

  • open a new Terminal, then type the following commands (press Enter after each line):

      sudo add-apt-repository ppa:yannubuntu/boot-repair
      sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
     sudo apt-get update
     sudo apt-get install -y boot-repair && (boot-repair &)

Using Boot-Repair

Recommended repair

launch Boot-Repair from either :
    the Dash (the Ubuntu logo at the top-left of the screen)

    or System->Administration->Boot-Repair menu (Ubuntu 10.04 only)
    or by typing 'boot-repair' in a terminal 

Then click the "Recommended repair" button. When repair is finished, note the URL (paste.ubuntu.com/XXXXX) that appeared on a paper, then reboot and check if you recovered access to your OSs.
If the repair did not succeed, indicate the URL to people who help you by email or forum.

This will work for me. I hope this is help you.


I am posting this as I just hit this bug.

For me, on my hardware …

  1. As you boot, enter your bios -> disable secure boot

  2. Ubuntu should now boot …

  3. Install and run boot-repair

    sudo add-apt-repository ppa:yannubuntu/boot-repair
    sudo apt-get update
    sudo apt-get install -y boot-repair && boot-repair
  4. Run boot-repair, go with the default options. As you run boot repair it will ask you to run a few additional commands.

    Apparently the upgrade to 14.04 does NOT include signed kernel images (you will see in the error messages).

  5. After you this finishes, you should be able to re-enable secure boot and Ubuntu will boot.

WARNING – Although this repaired Ubuntu, it trashed Windows and although I can get Windows to boot, Windows is throwing warnings about missing EFI files and I can not repair it when booting from the recovery disk (yes I ran all the commands to fix the windows boot, at least the ones that were provided with the windows repair disk. I did not provide those details as they are available on Google and the fix is unrelated to Ubuntu).

This is quite the nasty little bug when upgrading from LTS -> LTS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.