2

Finally I have something to ask and a problem which I cannot solve just googling.

As I said in the title, resume from suspend doesn't work on my macbookpro 4.1 with Ubuntu 14.04 installed. Not even with clean live cd. After resuming from suspend and logging, destop appears without Unity or other menus and totally freezes not even mouse pointer can be moved. If powerbutton is pressed shortly in the stuck situation result is 1/10s showed commandline error message(may I should take videoclip of that?) and finally blank screen which requires long press of powerbutton. CTRL-ALT-Fx -terminals doesn't work on the situation. Suspend worked greatly with 12.10, so what has been broken this feature and what I can do? That macbookpro is my thirtiary computer, so the the problem is not big for me. I guess that problem is that some of the kernel modules cannot wakeup or X-windowing is confused but those are only guesses. I know that mac-users are a marginal group of Ubuntu users, but I would be glad as Ubuntu enthusiast if somebody knows the workaround.

Br. Mikko

  • Is this 14.04 or 13.10? – Tim Aug 15 '14 at 15:51
  • The problem is with both, currently 14.04 – user124044 Aug 15 '14 at 16:17
  • Can't be 13.10 since that is end of life and we don't support it anymore ;) – Rinzwind Sep 22 '14 at 14:29
1

I had the same issue on the same setup. Per the community wiki instructions for the MBP 3,1 revision

I switched the nvidia-331 using the Additional Drivers utility, and the suspend problem cleared up. (It did, however, cause problems with the Ubuntu boot splash screen not appearing. This is fixable -- see The instructions here at binarytides -- though note an important error in those instructions: The file /etc/initramfs-tools/conf.d/splash should include only FRAMEBUFFER=y (minus the quotes), NOT echo FRAMEBUFFER=y as shown.)

If you don't want to mess with the video drivers, the community wiki page for using 13.04 Raring Ringtail with MBP 4,1 models describes a fix involving creation of a script called macbook.sh in /etc/pm/sleep.d (use same URL as first link above, but change "3-1" to "4-1" and "Trusty" to "Raring"). I haven't tested this, but it may be worth a shot.

0

There is a bug report similar to this issue:

https://bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/1371159

In that case, suspend and hibernate do not work at all.

0

According dmesg, the problem is not same that Albert proposes. I solved the problem installing ubuntu 12.04 and it works well. Even clean install of 14.04 did't work when resuming from suspend. Dmesg errors were same with 14.04 live cd, so if anybody is interested I could do some debugging.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.