I recently got a new laptop (TOSHIBA Satellite C50-B-14D) and just installed a new HDD for it and intended to install Ubuntu 14.04.1 on it. I must have done this about 5 times now, but after inserting my bootable usb and going through the install process and restarting my laptop it comes up with the message "Reboot and select proper boot device or Insert boot Media in selected Boot device and press a key" and when I install it again it says Ubuntu is already there.

  • Completely new HD – Oliver Waite Aug 15 '14 at 13:54
  • Yes. But i also tried manual partitioning but nothing seems to work. – Oliver Waite Aug 15 '14 at 14:01
  • WD Mainstream 2.5" Internal Hard Drive - 1 TB I dont think that is the problem though. I've also tried installation on my the old HDD and came up with the same issue. – Oliver Waite Aug 15 '14 at 14:04
  • I already changed it to CSM boot. – Oliver Waite Aug 15 '14 at 14:07
  • K - the site is asking us to move to chat, but you don't have enough reputation for that. I'll delete a few of my prior comments. The attached link is for a different toshiba, but may be applicable to your problem linuxontoshiba.blogspot.se/2014/05/… – Charles Green Aug 15 '14 at 14:16

I've had this error message before. Toshiba's fail-safe is:

Power off device. Hold 0 (zero). While holding 0, power on device. While holding 0 you can press F2 (or F12) to enter BIOS (or the Boot Menu).

|improve this answer|||||

Change the boot order in you BIOS settings.
Make sure that the drive you installed Ubuntu on is on top of the list. If it works, you can move the drive further down until it's not working anymore. That way you can see what's causing the problem.

|improve this answer|||||
  • I cant seem to access my BIOS settings. I've tried F2, ESC+F1 and F8, but nothing seems to work. – Oliver Waite Aug 15 '14 at 13:49
  • It should say which key to press as soon as you power on the PC. Maybe also try DEL. – jnuk Aug 15 '14 at 13:51
  • It's F12 and HDD is at the top of the list. And even from booting from HDD i still get the same message. – Oliver Waite Aug 15 '14 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.