11

Since upgrading to Ubuntu 14.04 whenever I open a new Tab in the Terminal I am in the Home directory instead of the directory I was in in the other Tab.

How can I change it to stay in the directory from the Tab I opened it from?

1
  • 1
    Read this, may be this is a bug
    – c0rp
    Aug 15 '14 at 8:47
11

I think you are dealing with this bug. You will find there in the comment #2 the following workaround (thanks to Tim (darkxst) for it):

add the following line to the end of ~/.bashrc file:

. /etc/profile.d/vte.sh
1
  • Hm this doesn't work for me in Ubuntu 15.10 with zsh (and changing .zshrc) Jan 21 '16 at 20:01
1

The

. /etc/profile.d/vte.sh

workaround did not work for me. However, what did work is: I finally discovered that in the Profile Preferences' "Command" tab (right click in the terminal->Profiles) unchecking "Run a custom command instead of my shell", if it is checked, can also solve this issue.

1

In 16.04 a symlink may be missing. The file can be found at /etc/profile.d/vte-2.91.sh

Source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.