0

I noticed this after upgrading my desktop (commodity PC parts) from 12.04lts to 14.04 lts. Upgrade done with updater after being notified yesterday that there was a new release available. I've been poking at it for some hours on several computers. Two have the problem and one seems fine. Starting with this desktop the logs show a difference between versions on the same machine in the syslog bluetooth startup.

The bluetooth device is a Logitech Edge keyboard with a USB Bluetooth 2.0 adapter.

12.04lts (working):

Aug 12 21:27:26 ceora bluetoothd[1058]: Bluetooth daemon 4.98
Aug 12 21:27:26 ceora bluetoothd[1058]: Starting SDP server
Aug 12 21:27:26 ceora bluetoothd[1058]: Failed to init alert plugin
Aug 12 21:27:26 ceora bluetoothd[1058]: Failed to init time plugin
Aug 12 21:27:26 ceora bluetoothd[1058]: Failed to init proximity plugin
Aug 12 21:27:26 ceora bluetoothd[1058]: Failed to init gatt_example
plugin
Aug 12 21:27:26 ceora bluetoothd[1058]: Listening for HCI events on hci0
Aug 12 21:27:26 ceora bluetoothd[1058]: HCI dev 0 up
Aug 12 21:27:27 ceora bluetoothd[1058]: Adapter /org/bluez/1058/hci0 has
been enabled
Aug 12 21:27:53 ceora bluetoothd[1058]: Endpoint registered:
sender=:1.39 path=/MediaEndpoint/HFPAG
Aug 12 21:27:53 ceora bluetoothd[1058]: Endpoint registered:
sender=:1.39 path=/MediaEndpoint/A2DPSource
Aug 12 21:27:53 ceora bluetoothd[1058]: Endpoint registered:
sender=:1.39 path=/MediaEndpoint/A2DPSink
Aug 12 21:28:19 ceora bluetoothd[1058]: Endpoint registered:
sender=:1.53 path=/MediaEndpoint/HFPAG
Aug 12 21:28:19 ceora bluetoothd[1058]: Endpoint registered:
sender=:1.53 path=/MediaEndpoint/A2DPSource
Aug 12 21:28:19 ceora bluetoothd[1058]: Endpoint registered:
sender=:1.53 path=/MediaEndpoint/A2DPSink
Aug 12 21:28:34 ceora bluetoothd[1058]: Endpoint unregistered:
sender=:1.39 path=/MediaEndpoint/HFPAG
Aug 12 21:28:34 ceora bluetoothd[1058]: Endpoint unregistered:
sender=:1.39 path=/MediaEndpoint/A2DPSource
Aug 12 21:28:34 ceora bluetoothd[1058]: Endpoint unregistered:
sender=:1.39 path=/MediaEndpoint/A2DPSink

14.04lts (broken):

Aug 14 12:30:18 ceora bluetoothd[5360]: Bluetooth daemon 4.101
Aug 14 12:30:18 ceora bluetoothd[5360]: Starting SDP server
Aug 14 12:30:18 ceora bluetoothd[5360]: DIS cannot start: GATT is disabled
Aug 14 12:30:18 ceora bluetoothd[5360]: Failed to init deviceinfo plugin
Aug 14 12:30:18 ceora bluetoothd[5360]: Failed to init proximity plugin
Aug 14 12:30:18 ceora bluetoothd[5360]: Failed to init time plugin
Aug 14 12:30:18 ceora bluetoothd[5360]: Failed to init alert plugin
Aug 14 12:30:18 ceora bluetoothd[5360]: Failed to init thermometer plugin
Aug 14 12:30:18 ceora bluetoothd[5360]: Failed to init gatt_example plugin
Aug 14 12:30:18 ceora bluetoothd[5360]: Bluetooth Management interface initialized

For the computer that works with 14.04 (a Dell mini 910):

Aug 14 12:32:12 dellmini bluetoothd[7378]: Bluetooth daemon 4.101
Aug 14 12:32:12 dellmini bluetoothd[7378]: Starting SDP server
Aug 14 12:32:12 dellmini bluetoothd[7378]: DIS cannot start: GATT is disabled
Aug 14 12:32:12 dellmini bluetoothd[7378]: Failed to init deviceinfo plugin
Aug 14 12:32:12 dellmini bluetoothd[7378]: Failed to init proximity plugin
Aug 14 12:32:12 dellmini bluetoothd[7378]: Failed to init time plugin
Aug 14 12:32:12 dellmini bluetoothd[7378]: Failed to init alert plugin
Aug 14 12:32:12 dellmini bluetoothd[7378]: Failed to init thermometer plugin
Aug 14 12:32:12 dellmini bluetoothd[7378]: Failed to init gatt_example plugin
Aug 14 12:32:12 dellmini bluetoothd[7378]: Bluetooth Management interface initialized
Aug 14 12:32:12 dellmini bluetoothd[7378]: Adapter /org/bluez/7378/hci0 has been enabled
Aug 14 12:32:12 dellmini bluetoothd[7378]: Endpoint registered: sender=:1.67 path=/MediaEndpoint/HFPAG
Aug 14 12:32:12 dellmini bluetoothd[7378]: Endpoint registered: sender=:1.67 path=/MediaEndpoint/HFPHS
Aug 14 12:32:12 dellmini bluetoothd[7378]: Endpoint registered: sender=:1.67 path=/MediaEndpoint/A2DPSource
Aug 14 12:32:12 dellmini bluetoothd[7378]: Endpoint registered: sender=:1.67 path=/MediaEndpoint/A2DPSink
Aug 14 12:32:12 dellmini bluetoothd[7378]: hci0: Load Long Term Keys (0x0013) failed: Not Supported (0x0c)

Note the line referring to Adapter /org/bluez/1058/hci0 is present in the working configurations and missing in the broken. I also have an Acer Aspire One running 14.04 that has the same symptoms/logs as my broken desktop and the bluetooth is broken there, too. I did have the bluetooth keyboard working on the Acer with either 13.04 or 13.10, but I can't remember which.

From the user interface the breakage shows itself in the System Settings -> Bluetooth as everything greyed out with No Bluetooth adapters found in the adapter list. The check box to Show Bluetooth status in the menu bar will check, but nothing shows.

  • I use the DiNovo Edge with the stock dongle and have no problems. Up until now. – LiveWireBT Aug 15 '14 at 2:15
1

The answer to my question seems to be that I need to hold the red button on the dongle when inserting it. The behavior is different than before, but seems reasonable. I never used the red button before.

I tested this through a warm reboot and cold shutdown. The connection survived both. I only needed to re-pair if I pulled the dongle out and reinserted it. To review, the steps to make it work are:

  1. Insert the dongle while holding down the red button on it.

  2. Open the System Settings -> Bluetooth utility. Now the option to turn on bluetooth is not greyed out and bluetooth turns on.

  3. Add the device and pair it and it works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.