11

For mysterious reasons dropbox is not working anymore. I have added few small pdf to my folder and it is syncing them for hours. I have tried to remove and reinstall dropbox but nothing is changed.

I suspect this can be due a possible recent ubuntu update. Has anyone the same problem or now how to solve it?

9

I had the same problem, I removed the .dropbox hidden folder (located at home directory) and reinstalled Dropbox again.

But according to https://www.dropbox.com/help/72 you can reset ownership an permissions running the following commands:

sudo chown "$USER" "$HOME"
sudo chown -R "$USER" ~/Dropbox ~/.dropbox ~/.dropbox-master
sudo chattr -R -i ~/Dropbox
sudo chmod -R u+rw ~/Dropbox ~/.dropbox ~/.dropbox-master
  • 1
    Why this answer has been downvoted? – Donbeo Aug 14 '14 at 22:18
  • 1
    I am wondering that too. – Akiva Aug 14 '14 at 22:22
  • 1
    your solution did not work for me. I have not the /dropbox-master folder. Even removing /dropbox-master from the previous code it is not working – Donbeo Aug 14 '14 at 23:33
  • Now it is working again. Maybe it was a problem of the dropbox server – Donbeo Aug 15 '14 at 8:34
  • I'm glad it's working again – Daniel Semblano Aug 15 '14 at 16:55
2

I have the same problem with Ubuntu 16.04. I ran dropbox from the terminal and it suggested to execute the following command to fix the problem, and restart dropbox:

echo fs.inotify.max_user_watches=100000 | sudo tee -a /etc/sysctl.conf; sudo sysctl -p

It worked for me :-)

  • Just "run dropbox from the terminal" is the best way to find the problem. Mine was out of disk space on that partition. – andrew lorien Jan 17 '17 at 0:58
2

I have a sync problem (16.04) which at least affects Dropbox uploading on eduroam, the WiFi where I work. Syncing does work when invoking Dropbox by terminal. To ensure upload, I've added

alias drop='dropbox stop && dropbox start && until [ "$(dropbox status)" = "Up to date" ] ; do dropbox status; sleep 1; done'

to my .bashrc file in my home folder. Running drop in terminal then stops and starts Dropbox and syncs, outputting status until finished. It's not pretty, but it works.

  • This was a good answer. My problem was disk space (d'oh), but running this script helped me find it. – andrew lorien Jan 17 '17 at 0:56
1

First check whether Dropbox has been installed properly...

Run this command in terminal:

dropbox status

If the output is Dropbox isn't running!

Then run the following command:

dropbox start 

Or if that doesn't work, try dropbox start -i to locate interpreter if possible.

Now Dropbox will start and automatically synchronize the updated files.

Fox next time you can run this command to start Dropbox automatically...

dropbox autostart
0

I tried everything at https://www.dropbox.com/help/72 to no avail. The only thing that worked for me (Dropbox 2.10.30 under Ubuntu 14.04) was plugging my computer to a wired internet connection.

0

Another possibility, if someone runs into such a problem:

I had the service stop working and so I updated to the latest version (currently 2.10.30). In ~/.dropbox-dist the main program has been changed from dropbox to dropboxd so my script in /etc/init.d had to be edited to reflect the change.

Line 4 in the popular Dropbox script should be

DAEMON=.dropbox-dist/dropboxd

(I ran into this problem in both Ubuntu 14.04 and 10.04, and 10.04 is still having problems, namely not syncing when a file is deleted and re-created.)

  • What do you mean by "popular Dropbox script"? I can't find anything that looks associated to Dropbox in my /etc/init.d folder. – Waldir Leoncio Sep 30 '14 at 19:33
  • 1
    Correct, there is no standard one. I'm still having problems on Ubuntu 10.04 but it works on 14.04. Here is the one I use from GitHub Gist. – sventech Oct 1 '14 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.