I recently installed Ubuntu 14.04 on a mac mini and bought a 2560 x 1080 ultrawide LG monitor for it. Problem is that it doesn't display the proper resolution, the maximum being 1920 x 1080 under ubuntu settings.

Any suggestions on what I should do?

Please give clear instructions as am not an Ubuntu expert.

  • What graphics card do you have?
    – Tim
    Aug 14, 2014 at 17:09
  • How do I check this? Aug 14, 2014 at 17:10
  • Umm lspci | grep VGA in the terminal. For example mine says 01:00.0 VGA compatible controller: NVIDIA Corporation, so I have a nvidia Graphics card.
    – Tim
    Aug 14, 2014 at 17:13
  • I just checked under settings, not terminal. Apparently it's a "Gallium 0.4 on NVAC". Aug 14, 2014 at 17:14
  • Terminal says this: 02:00.0 VGA compatible controller: NVIDIA Corporation C79 [GeForce 9400] (rev b1) Aug 14, 2014 at 17:17

6 Answers 6


2560x1080 for a 29" ultra wide monitor is not supported on Ubuntu 14.04 and 14.10.

Bug report: https://bugs.launchpad.net/ubuntu/+source/xrandr/+bug/1357804


The reason you don't see resolution option in nvdia-settings, is because you probably didn't install the nvidia driver. You should install the nvidia driver of your corresponding gpu

with this command : $ sudo apt-get install nvidia-current

or you can go to follow this link: http://www.nvidia.com/Download/index.aspx?lang=en-us .

After doing this reboot, and type in terminal: $ lspci -vnn | grep -i VGA -A 12

You should see : "Kernel driver in use: nvidia"

instead of ubuntu default driver "noveau".

After doing this type in terminal: $ gksudo nvidia-setting and change settings to desired resolution in " X server Display Configuration"


The typical way would be to solve this with a custom modeline that defines how the graphics driver should communicate with the panel.

How to add display resolution for an LCD in Ubuntu 12.04? xrandr problem

Contrary to suggestions for installing proprietary drivers, this would probably work best with the open source drivers.

Edit: It's probably worth to mention that the graphics port and the monitor cable also have to support the mode the screen requires to run the optimal resolution and refresh rate. Bad VGA/DVI/HDMI/DP cables and unsupported HDMI/DP modes or non Dual Link DVI ports can be an issue here.


I had the same problem in the same OS. Everything worked fine after I've updated to the latest Nvidia proprietary drivers. I see that you are also using a Nivida graphic card.

Step by step:

  1. Check if you are using an HDMI or Display Port cable
  2. Install the latest proprietary drivers from Nvidia.
  3. Execute the just installed Nvidia setting app and select the desired setting.

The newer Linux kernel most likely supports your hardware, 14.04 is running a rather ancient one. Consider upgrading to the newest kernel 4.8.2 by downloading the necessary .deb files from the Ubuntu mainline kernel repository at http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.2/

  • maybe first ask what kernel is currently used.
    – TiloBunt
    Oct 17, 2016 at 6:03

For me, only switching to Nouveau drivers helped.

  1. Install nouveau package, relevant to your distribution.
  2. Disable blacklisting from "/usr/lib/modprobe.d/nvidia.conf".
  3. Add noveau drivers to xorg configuration.

Reference: Missing 2560x1080 from Linux Nvidia Control Panel

  • Please provide the essential part of the solution. Share the link only as reference and more detail Apr 5, 2017 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.