13

Since updating to 14.04, I'm unable to set a lower volume. According to the alsamixer, it automatically mutes when I try to go below 18%.

How can I restore access to the quieter volumes? Ubuntu 14.04 running on a Dell Inspiron 1501

7
  • Are you sure it mutes, and isn't just that it is too quiet to hear? – Tim Aug 14 '14 at 12:55
  • Yes. looking in alsamixer, it goes from 18 to muted. listening in my headphones, it goes from "louder than I'd like" to "silence" – SFischer Aug 14 '14 at 13:01
  • What does the command pactl set-sink-volume 2 15% do? Does that also mute it, or go to 15%? – Tim Aug 14 '14 at 16:03
  • 1
    Yes. It also goes to silent. Using the pactl set-sink-volume 0 XX% command reveals that the sound cuts on at 17% and above and is silent at 16% and below (index 0 used, because others do not exist) – SFischer Aug 14 '14 at 18:09
  • That's very odd, I think it's a bug and needs to be reported on launchpad.net – Tim Aug 14 '14 at 18:10
7

Setting volume-limit works for headphones but will, probably, make sound too quiet while using other speakers.

As alternative solution, try setting ignore_dB=1 in /etc/pulse/default.pa.

load-module module-udev-detect ignore_dB=1

From ArchLinux Wiki

2
  • 2
    This fixes my issue with an USB sound card (041e:30d3 SoundBlaster Play). The pulse audio system volume now is in sync with the output "Speaker" mixer, both start at 0%. – istepaniuk Mar 24 '20 at 17:46
  • 2
    Works like a charm with a USB headset on ubuntu 20.10 – David B. Nov 17 '20 at 16:28
6

I found the solution here worked for me.

As root, you'll need to edit the file:

$ sudo vim /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common

Find the section that looks like the following:

[Element PCM]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

Add a new setting for volume-limit so it looks like this:

[Element PCM]
switch = mute
volume = merge
volume-limit = 0.05    # This is the new line
override-map.1 = all
override-map.2 = all-left,all-right

Then you need to restart PulseAudio with the following command:

$ pulseaudio -k

If you had any applications playing sound, they will be muted. You'll have to restart them to get sound again and then you can test your new settings.

The original author of the solution suggested setting volume-limit = 0.01, but I found that to be too quiet, so I use 0.05. You can test smaller or larger values to fit your preferences.

1
  • 2
    This is not a solution to the problem, it just reduces the volume of my whole system... – Xerus Sep 16 '18 at 19:29
3

I've also had this problem for several years now in all the releases of Ubuntu.

@Tim, it is already reported in launchpad. Related bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/443131

According to the last comment, this bug won't be fixed :(

PS: This was meant to be / should have been a comment like the ones above, but apparently I need 50 reputation points to be able to do that..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.